sys-apps/prctl: drop CPP detection
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 28 May 2020 08:20:35 +0000 (09:20 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 28 May 2020 08:20:53 +0000 (09:20 +0100)
While at it modernized build system up to recent automake.

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-apps/prctl/files/Makefile.am [new file with mode: 0644]
sys-apps/prctl/files/configure.ac [new file with mode: 0644]
sys-apps/prctl/files/prctl-1.6-configure.in.patch [new file with mode: 0644]
sys-apps/prctl/prctl-1.6-r1.ebuild [new file with mode: 0644]

diff --git a/sys-apps/prctl/files/Makefile.am b/sys-apps/prctl/files/Makefile.am
new file mode 100644 (file)
index 0000000..aff321e
--- /dev/null
@@ -0,0 +1,3 @@
+bin_PROGRAMS  = prctl
+prctl_SOURCES = prctl.c
+man_MANS      = prctl.1
diff --git a/sys-apps/prctl/files/configure.ac b/sys-apps/prctl/files/configure.ac
new file mode 100644 (file)
index 0000000..d29ea9d
--- /dev/null
@@ -0,0 +1,13 @@
+AC_INIT([prctl], [1.6])
+AC_CONFIG_SRCDIR([prctl.c])
+AM_INIT_AUTOMAKE([foreign])
+
+AC_PROG_CC
+
+AC_HEADER_STDC
+AC_CHECK_HEADERS(unistd.h)
+
+AC_CHECK_FUNCS(strerror)
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT
diff --git a/sys-apps/prctl/files/prctl-1.6-configure.in.patch b/sys-apps/prctl/files/prctl-1.6-configure.in.patch
new file mode 100644 (file)
index 0000000..492733e
--- /dev/null
@@ -0,0 +1,20 @@
+Restored configure.in based on tarball's configure
+--- /dev/null
++++ b/configure.in
+@@ -0,0 +1,16 @@
++AC_INIT(prctl.c)
++
++AC_PROG_LN_S
++AC_PROG_CC
++AC_PROG_CPP
++AC_PROG_INSTALL
++
++
++AC_HEADER_STDC
++AC_CHECK_HEADERS(unistd.h)
++
++
++AC_CHECK_FUNCS(strerror)
++AC_SUBST(ASCPP)
++AC_SUBST(INSTALL)
++AC_OUTPUT(Makefile)
diff --git a/sys-apps/prctl/prctl-1.6-r1.ebuild b/sys-apps/prctl/prctl-1.6-r1.ebuild
new file mode 100644 (file)
index 0000000..419cae8
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Tool to query and modify process behavior"
+HOMEPAGE="https://sourceforge.net/projects/prctl/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+PATCHES=(
+       "${FILESDIR}"/${P}-no-implicits.patch
+)
+
+src_prepare() {
+       default
+
+       cp "${FILESDIR}"/{Makefile.am,configure.ac} ./ || die
+       eautoreconf
+}