dev-libs/log4cplus: Version bump to 1.1.3-rc7
authorDavid Seifert <soap@gentoo.org>
Sat, 17 Sep 2016 23:33:37 +0000 (01:33 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 18 Sep 2016 00:32:08 +0000 (02:32 +0200)
Gentoo-bug: 594102
* EAPI=6

Package-Manager: portage-2.3.0

dev-libs/log4cplus/Manifest
dev-libs/log4cplus/log4cplus-1.1.3_rc7.ebuild [new file with mode: 0644]

index 2a1fc06fd383e1ccd86eb5b43cc3a30ea3f2896a..8e20108ecbd8fd6dfba5eb814a8d17e6b9e07fe1 100644 (file)
@@ -1 +1,2 @@
 DIST log4cplus-1.1.2.tar.bz2 541761 SHA256 c46d56c96873dcb525791b5ea639d1415e74b1de99d51b657336cb6ebb72ed93 SHA512 a3bb619a0c005c63b533fa95fafe6c772dfc1b85f9b9556264b75a458398b81c48c17813ea04d07e3ea902f3f5f604b59dac7922412c5d0e0339200a453515b7 WHIRLPOOL a5b5f35b970150677f3336b954fb0ceac74517ae620427908f2d93108f09021ccdbf58a4044cfa51178a6624dff88833d0ac4f6c52136441310535bb0d79a264
+DIST log4cplus-1.1.3-rc7.tar.bz2 562969 SHA256 614bfd8a2e88510f7fa497b4aa12e763aa05cf0771d06284db385e5fd9fda5bb SHA512 6854a966dfd5a2b807778e34957ea33c43a340b8be71a1a989941ec6c6fdc22d181dc2f0bb0e87910c77417a9f5c4f07d4fbd8f13eadffe82adef10a1e00ef02 WHIRLPOOL 457cbd540508094450f363656964c80fc66a2cc9be887605c73001431bbff04ac4cdee5d0fc22ece86b5b7760e120eecffd9a129e95ad0c174ca6ace7c944e01
diff --git a/dev-libs/log4cplus/log4cplus-1.1.3_rc7.ebuild b/dev-libs/log4cplus/log4cplus-1.1.3_rc7.ebuild
new file mode 100644 (file)
index 0000000..603c2c6
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="C++ port of the Log for Java (log4j) logging library"
+HOMEPAGE="http://log4cplus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}-stable/${PV%_*}/${MY_P}.tar.bz2"
+
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+SLOT="0/1.1-9"
+KEYWORDS="~amd64 ~x86"
+IUSE="iconv test threads working-locale working-c-locale qt4"
+REQUIRED_USE="?? ( iconv working-locale working-c-locale )"
+
+RDEPEND="iconv? ( virtual/libiconv )
+       qt4? ( dev-qt/qtcore:4 )"
+DEPEND="virtual/pkgconfig
+       ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+       default
+
+       if ! use test; then
+               sed -i -e 's:tests::' Makefile.in || die
+       fi
+}
+
+src_configure() {
+       econf \
+               --disable-static \
+               $(use_enable threads) \
+               $(use_with iconv) \
+               $(use_with working-locale) \
+               $(use_with working-c-locale) \
+               $(use_with qt4 qt)
+}
+
+src_compile() {
+       default
+       use test && emake -C tests
+}
+
+src_test() {
+       cd tests/ || die
+
+       local t
+       for t in appender customloglevel fileappender filter \
+        hierarchy loglog ndc ostream patternlayout performance priority \
+        propertyconfig timeformat; do
+               einfo "Running test \"${t}_test\""
+               pushd "${t}_test/" >/dev/null || die
+               ./${t}_test || die "Running ${t}_test failed!"
+               popd >/dev/null || die
+       done
+
+       if use threads; then
+               for t in configandwatch thread; do
+                       einfo "Running test \"${t}_test\""
+                       pushd "${t}_test/" >/dev/null || die
+                       ./${t}_test || die "Running ${t}_test failed!"
+                       popd >/dev/null || die
+               done
+       fi
+}
+
+src_install() {
+       default
+       dodoc docs/unicode.txt
+
+       # package provides .pc files
+       find "${D}" -name '*.la' -delete || die
+}