app-office/ledger: bump to 3.1.1
authorErik Mackdanz <stasibear@gentoo.org>
Sun, 21 Feb 2016 18:42:26 +0000 (12:42 -0600)
committerErik Mackdanz <stasibear@gentoo.org>
Sun, 21 Feb 2016 18:42:26 +0000 (12:42 -0600)
Adds IUSE=python

Package-Manager: portage-2.2.27

app-office/ledger/Manifest
app-office/ledger/files/50ledger-gentoo-3.1.1.el [new file with mode: 0644]
app-office/ledger/ledger-3.1.1.ebuild [new file with mode: 0644]
app-office/ledger/metadata.xml

index 40a419e1b4d4db1c553e19f9bab438df840355d2..778c657a4f85680a7da5f3cb1f81052f797c5230 100644 (file)
@@ -1,2 +1,3 @@
 DIST ledger-2.6.3.tar.gz 551325 SHA256 e2c99d930fcf64b7fa901215c7fa25e3327f6365e8ee049620ef3632d53bf363 SHA512 825e670d25d2f8d1791480fb5da4190f7b342ecc9b47bca60fd6f0e606e5af5f3f767ec7043339660396ef4c90451f4a4122d812b8761acf4ea964b67dbd43b5 WHIRLPOOL e6d351ce8899079daa9cb0d1f9493b2b551a6d44e8ad7949c28ac8e544f80c87d54f06b350adfc21c4c8582e9042547313a506fa74096671bae30b462ae3e2df
+DIST ledger-3.1.1.tar.gz 842364 SHA256 90f06561ab692b192d46d67bc106158da9c6c6813cc3848b503243a9dfd8548a SHA512 3f81b98a414cdfc0e272de4e958770149fb1acc8bda880d270e1459ce35294a220c52820bb9af49a751ac3a80b878f81fc7799ba41e0a1be43eba72081351bf5 WHIRLPOOL 89a83818adbe206167dbfc999dd589f1943d199cf84979fa82754f597a863c115fec85bbdabc4413714b4253502833170e6327bfc0d2321c392b9a3d73400061
 DIST ledger-3.1.tar.gz 817624 SHA256 eeb5d260729834923fc94822bcc54ca3080c434f81466a3f5dc4274b357ce694 SHA512 caa84330eee05d3e88820e8afd4a906d22f6aaa9de4abc2f6813636754e052e6ec4d1b3d2fce68215aededc72651405c62aaf16a2c1b69d34e1b10ffece48519 WHIRLPOOL fc3ce5e8eb59e1d4f83101063ebefd1379172c1be0e4f504079519924859b8127d616e7e3714837be49c7b38674b1684e321347d1f8561aeeba586b538341142
diff --git a/app-office/ledger/files/50ledger-gentoo-3.1.1.el b/app-office/ledger/files/50ledger-gentoo-3.1.1.el
new file mode 100644 (file)
index 0000000..1c2c5bd
--- /dev/null
@@ -0,0 +1,5 @@
+
+;;; app-office/ledger site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ledger-mode "ledger-mode" "A mode for editing ledger data files." t)
diff --git a/app-office/ledger/ledger-3.1.1.ebuild b/app-office/ledger/ledger-3.1.1.ebuild
new file mode 100644 (file)
index 0000000..13b8cfb
--- /dev/null
@@ -0,0 +1,125 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit check-reqs cmake-utils elisp-common python-single-r1
+
+DESCRIPTION="A double-entry accounting system with a command-line reporting interface"
+HOMEPAGE="http://ledger-cli.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc emacs python"
+
+SITEFILE=50${PN}-gentoo-${PV}.el
+
+CHECKREQS_MEMORY=8G
+
+COMMON_DEPEND="
+       dev-libs/gmp:0
+       dev-libs/mpfr:0
+       emacs? ( virtual/emacs )
+       python? ( dev-libs/boost:=[python] )
+       !python? ( dev-libs/boost:= )
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       python? ( dev-python/cheetah )
+"
+DEPEND="
+       ${COMMON_DEPEND}
+       dev-libs/utfcpp
+       doc? ( sys-apps/texinfo )
+"
+
+DOCS=(README.md)
+
+# Building with python integration seems to fail without 8G available
+# RAM(!)  Since the memory check in check-reqs doesn't count swap, it
+# may be unfair to fail the build entirely on the memory test alone.
+# Therefore check-reqs_pkg_pretend is deliberately omitted so that we
+# ewarn but not not eerror.
+pkg_pretend() {
+       :
+}
+pkg_setup() {
+       if use python; then
+          check-reqs_pkg_setup
+          python-single-r1_pkg_setup
+       fi
+}
+
+src_prepare() {
+       # Want to type "info ledger" not "info ledger3"
+       sed -i -e 's/ledger3/ledger/g' \
+       doc/ledger3.texi \
+       doc/CMakeLists.txt \
+       test/CheckTexinfo.py \
+       tools/cleanup.sh \
+       tools/gendocs.sh \
+       tools/prepare-commit-msg \
+       tools/spellcheck.sh \
+       || die "Failed to update info file name in file contents"
+
+       mv doc/ledger{3,}.texi || die "Failed to rename info file name"
+}
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake-utils_use_build emacs EMACSLISP)
+               $(cmake-utils_use_build doc DOCS)
+               $(cmake-utils_use_build doc WEB_DOCS)
+               $(cmake-utils_use_use python PYTHON)
+               -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+       )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+
+       use doc && cmake-utils_src_make doc
+}
+
+src_install() {
+       # Prevent installing ledger.so into python site-packages.  It's an
+       # unnecessary copy of libledger.so and generates security warnings.
+       sed -i -e '/python/d' ../${P}_build/src/cmake_install.cmake
+
+       enable_cmake-utils_src_install
+
+       # This source dir appears to include some helper code for serving
+       # reports to a browser ("ledger server").  I can't quite get it to
+       # work and the docs say it's a work-in-progress.  It's a little
+       # interesting, though, so I'll leave these installed as a preview of
+       # features to come.
+       if use python; then
+               mv python ${PN} || die "Couldn't rename python module static files dir"
+               python_domodule ${PN}
+       fi
+
+       use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+}
+
+pkg_postinst() {
+       use emacs && elisp-site-regen
+
+       einfo
+       einfo "Since version 3, vim support is released separately."
+       einfo "See https://github.com/ledger/vim-ledger"
+       einfo
+}
+
+pkg_postrm() {
+       use emacs && elisp-site-regen
+}
+
+# rainy day TODO:
+# - IUSE test
index 9d91b41fc7d9dfb15f9637c235242b515deef8af..56dda141644b5876bd8cc504437040c62e2ec6cf 100644 (file)
@@ -1,6 +1,9 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
+  <maintainer type="person">
+    <email>stasibear@gentoo.org</email>
+  </maintainer>
   <maintainer type="person">
     <email>yac@gentoo.org</email>
   </maintainer>