x11-plugins/wmdots: replace ":" as sed delimiter
authorBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Feb 2020 21:04:08 +0000 (22:04 +0100)
committerBernard Cafarelli <voyageur@gentoo.org>
Mon, 24 Feb 2020 21:04:17 +0000 (22:04 +0100)
Closes: https://bugs.gentoo.org/710714
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmdots/wmdots-0.2_beta-r1.ebuild

index e38905e132927b47a05d6ec4f04c28b9b123470a..5aaba6401e1ce5dcfe77d202c21a52970f1d3bb3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -23,14 +23,14 @@ S="${WORKDIR}/${PN}"
 src_prepare() {
        default
        eapply "${FILESDIR}"/${P}-stringh.patch
-       sed -e "s:cc:$(tc-getCC):g" \
-               -e "s:-g -O2:${CFLAGS}:g" -i Makefile || die
+       sed -e "s|cc|$(tc-getCC)|g" \
+               -e "s|-g -O2|${CFLAGS}|g" -i Makefile || die
 
        #Fix compilation target
-       sed -e "s:wmifs:wmdots:" -i Makefile || die
+       sed -e "s|wmifs|wmdots|" -i Makefile || die
 
        #Honour Gentoo LDFLAGS, see bug #336982
-       sed -e "s:-o wmdots:\$(LDFLAGS) -o wmdots:" -i Makefile || die
+       sed -e "s|-o wmdots|\$(LDFLAGS) -o wmdots|" -i Makefile || die
 }
 
 src_compile() {