app-editors/vim-core: Version bump (v8.2.0814)
authorMikle Kolyada <zlogene@gentoo.org>
Sun, 24 May 2020 11:01:51 +0000 (14:01 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sun, 24 May 2020 11:01:51 +0000 (14:01 +0300)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
app-editors/vim-core/Manifest
app-editors/vim-core/vim-core-8.2.0814.ebuild [new file with mode: 0644]

index 5938276ae5531d55e034dcb9aa56f84af0bb0eb1..30bd1b8eb791f595987bd8319106216a939eb43e 100644 (file)
@@ -3,3 +3,4 @@ DIST vim-8.2.0360-gentoo-patches.tar.xz 2612 BLAKE2B a9273a686b31dd873b25bfc07f7
 DIST vim-8.2.0360.tar.gz 14842830 BLAKE2B fe3a13cb4bef4ada1bd13cdc80aa9a4ab275d1ff16a7f5308109adc7c5a3459393e1c8153fa32a972141b27cce3aaff50c59416d1ba32e4dca03074be49705a9 SHA512 183bcb5cc73290193de99beb69b56b64efa37db9d905c6e76a51ac727f4447f76346dde632e2dfae9d289abb4b9ca11a14f7e350eaa699fc2c3c7c2e35fc20b2
 DIST vim-8.2.0508.tar.gz 14885937 BLAKE2B 70d9cbaa69fac168e6719ef6ee0fadef21bc0b4c17e3c01d983cfe7d75ec831089845aae2f4ca2b5eba02ea24664dc968b0d472254db45e13a5a1f9cdc62253a SHA512 0cbe7cb8d16ac9ed2e6b2f7031bf3b962bcfa199ef7421dfa549fd53f42eb00fc20a14d0df13fcdb4b5f06c88e659086f8d277797824e628133ebd66c72232b6
 DIST vim-8.2.0638.tar.gz 14922315 BLAKE2B 12a8a272e1167ec845d2a5ab3b884f8d327e7b73a49fad2c7cafcd0bd5690c8c21d6b9e1b6211fd6ef8908ea93019c483ec5de74b50cf1fea8fbfc6f63b751df SHA512 4fc3aca0f3337b35d98281d1c7d5cd733bf14fbd1c3e382208ff950199125b6e4606bb7487310caf793eb6b2d1c6e719bce19b53d4d55a26354649c13b727a92
+DIST vim-8.2.0814.tar.gz 14953478 BLAKE2B fd4155ec749bd9a705e8114ff7f8cc321182c9286733ff2f665e265ec0af830f9e70c730b8d0215f6db1f73a8e2f878d22932a72c8dbfe921591be7adcdaab00 SHA512 4ddd9e2d30719f931cadd1a4de5700736f641f4b074378d9ea1462a90b81975ce8e8c3ca2e3a1e15ac0288824eef5b0f0a3e31482f7637c450c6d7e52c8f40d2
diff --git a/app-editors/vim-core/vim-core-8.2.0814.ebuild b/app-editors/vim-core/vim-core-8.2.0814.ebuild
new file mode 100644 (file)
index 0000000..28ba2d3
--- /dev/null
@@ -0,0 +1,225 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VIM_VERSION="8.2"
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
+
+if [[ ${PV} == 9999* ]] ; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/vim/vim.git"
+       EGIT_CHECKOUT_DIR=${WORKDIR}/vim-${PV}
+else
+       SRC_URI="https://github.com/vim/vim/archive/v${PV}.tar.gz -> vim-${PV}.tar.gz
+               https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="vim and gvim shared files"
+HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
+
+SLOT="0"
+LICENSE="vim"
+IUSE="nls acl minimal"
+
+DEPEND="sys-devel/autoconf"
+# avoid icon file collision bug #673880
+RDEPEND="!!<app-editors/gvim-8.1.0648"
+PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
+
+S=${WORKDIR}/vim-${PV}
+
+pkg_setup() {
+       # people with broken alphabets run into trouble. bug 82186.
+       unset LANG LC_ALL
+       export LC_COLLATE="C"
+
+       # Gnome sandbox silliness. bug #114475.
+       mkdir -p "${T}"/home || die "mkdir -p failed"
+       export HOME="${T}"/home
+}
+
+src_prepare() {
+       if [[ ${PV} != 9999* ]] ; then
+               # Gentoo patches to fix runtime issues, cross-compile errors, etc
+               eapply "${WORKDIR}"/patches
+       fi
+
+       # Fixup a script to use awk instead of nawk
+       sed -i \
+               -e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
+               "${S}"/runtime/tools/mve.awk || die "sed failed"
+
+       # See #77841. We remove this file after the tarball extraction.
+       rm -v "${S}"/runtime/tools/vimspell.sh || die "rm failed"
+
+       # Read vimrc and gvimrc from /etc/vim
+       echo '#define SYS_VIMRC_FILE "'${EPREFIX}'/etc/vim/vimrc"' >> "${S}"/src/feature.h
+       echo '#define SYS_GVIMRC_FILE "'${EPREFIX}'/etc/vim/gvimrc"' >> "${S}"/src/feature.h
+
+       # Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
+       # Hopefully this pattern won't break for a while at least.
+       # This fixes bug 29398 (27 Sep 2003 agriffis)
+       sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
+               "${S}"/runtime/doc/syntax.txt \
+               "${S}"/runtime/doc/tagsrch.txt \
+               "${S}"/runtime/doc/usr_29.txt \
+               "${S}"/runtime/menu.vim \
+               "${S}"/src/configure.ac || die 'sed failed'
+
+       # Don't be fooled by /usr/include/libc.h.  When found, vim thinks
+       # this is NeXT, but it's actually just a file in dev-libs/9libs
+       # This fixes bug 43885 (20 Mar 2004 agriffis)
+       sed -i 's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed'
+
+       # gcc on sparc32 has this, uhm, interesting problem with detecting EOF
+       # correctly. To avoid some really entertaining error messages about stuff
+       # which isn't even in the source file being invalid, we'll do some trickery
+       # to make the error never occur. bug 66162 (02 October 2004 ciaranm)
+       find "${S}" -name '*.c' | while read c; do
+           echo >> "$c" || die "echo failed"
+       done
+
+       # Try to avoid sandbox problems. Bug #114475.
+       if [[ -d "${S}"/src/po ]]; then
+               sed -i -e \
+                       '/-S check.vim/s,..VIM.,ln -s $(VIM) testvim \; ./testvim -X,' \
+                       "${S}"/src/po/Makefile || die "sed failed"
+       fi
+
+       cp -v "${S}"/src/config.mk.dist "${S}"/src/auto/config.mk || die "cp failed"
+
+       # Bug #378107 - Build properly with >=perl-core/ExtUtils-ParseXS-3.20.0
+       sed -i -e \
+               "s:\\\$(PERLLIB)/ExtUtils/xsubpp:${EPREFIX}/usr/bin/xsubpp:" \
+               "${S}"/src/Makefile || die 'sed for ExtUtils-ParseXS failed'
+
+       eapply_user
+}
+
+src_configure() {
+       local myconf
+
+       # Fix bug 37354: Disallow -funroll-all-loops on amd64
+       # Bug 57859 suggests that we want to do this for all archs
+       filter-flags -funroll-all-loops
+
+       # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
+       # everyone since previous flag filtering bugs have turned out to affect
+       # multiple archs...
+       replace-flags -O3 -O2
+
+       # Fix bug 18245: Prevent "make" from the following chain:
+       # (1) Notice configure.ac is newer than auto/configure
+       # (2) Rebuild auto/configure
+       # (3) Notice auto/configure is newer than auto/config.mk
+       # (4) Run ./configure (with wrong args) to remake auto/config.mk
+       sed -i 's# auto/config\.mk:#:#' src/Makefile || die "Makefile sed failed"
+
+       # Remove src/auto/configure file.
+       rm -v src/auto/configure || die "rm configure failed"
+
+       emake -j1 -C src autoconf
+
+       # This should fix a sandbox violation (see bug 24447). The hvc
+       # things are for ppc64, see bug 86433.
+       for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
+               if [[ -e "${file}" ]]; then
+                       addwrite $file
+               fi
+       done
+
+       # Let Portage do the stripping. Some people like that.
+       export ac_cv_prog_STRIP="$(type -P true ) faking strip"
+
+       # Keep Gentoo Prefix env contained within the EPREFIX
+       use prefix && myconf+=" --without-local-dir"
+
+       econf \
+               --with-modified-by=Gentoo-${PVR} \
+               --enable-gui=no \
+               --without-x \
+               --disable-darwin \
+               --disable-perlinterp \
+               --disable-pythoninterp \
+               --disable-rubyinterp \
+               --disable-gpm \
+               --disable-selinux \
+               $(use_enable nls) \
+               $(use_enable acl) \
+               ${myconf}
+}
+
+src_compile() {
+       emake -j1 -C src auto/osdef.h objects
+       emake tools
+}
+
+src_test() { :; }
+
+src_install() {
+       local vimfiles=/usr/share/vim/vim${VIM_VERSION/.}
+
+       dodir /usr/{bin,share/{man/man1,vim}}
+       emake -C src \
+               installruntime \
+               installmanlinks \
+               installmacros \
+               installtutor \
+               installtutorbin \
+               installtools \
+               install-languages \
+               DESTDIR="${D}" \
+               BINDIR="${EPREFIX}"/usr/bin \
+               MANDIR="${EPREFIX}"/usr/share/man \
+               DATADIR="${EPREFIX}"/usr/share
+
+       keepdir ${vimfiles}/keymap
+
+       # default vimrc is installed by vim-core since it applies to
+       # both vim and gvim
+       insinto /etc/vim/
+       newins "${FILESDIR}"/vimrc-r5 vimrc
+       eprefixify "${ED}"/etc/vim/vimrc
+
+       if use minimal; then
+               # To save space, install only a subset of the files.
+               # Helps minimalize the livecd, bug 65144.
+               eshopts_push -s extglob
+
+               rm -rv "${ED}${vimfiles}"/{compiler,doc,ftplugin,indent} || die "rm failed"
+               rm -rv "${ED}${vimfiles}"/{macros,print,tools,tutor} || die "rm failed"
+               rm -v "${ED}"/usr/bin/vimtutor || die "rm failed"
+
+               local keep_colors="default"
+               ignore=$(rm -fr "${ED}${vimfiles}"/colors/!(${keep_colors}).vim )
+
+               local keep_syntax="conf|crontab|fstab|inittab|resolv|sshdconfig"
+               # tinkering with the next line might make bad things happen ...
+               keep_syntax="${keep_syntax}|syntax|nosyntax|synload"
+               ignore=$(rm -fr "${ED}${vimfiles}"/syntax/!(${keep_syntax}).vim )
+
+               eshopts_pop
+       fi
+
+       newbashcomp "${FILESDIR}"/xxd-completion xxd
+
+       # install gvim icon since both vim/gvim desktop files reference it
+       doicon -s scalable "${FILESDIR}"/gvim.svg
+}
+
+pkg_postinst() {
+       # update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # update icon cache
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       # Update documentation tags (from vim-doc.eclass)
+       update_vim_helptags
+
+       # update icon cache
+       xdg_icon_cache_update
+}