net-misc/exabgp-3.4.28-r1: revbump, add init script, logrotate, etc
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 20 May 2020 01:05:16 +0000 (18:05 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 20 May 2020 01:06:09 +0000 (18:06 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
net-misc/exabgp/exabgp-3.4.28-r1.ebuild [moved from net-misc/exabgp/exabgp-3.4.28.ebuild with 55% similarity]

similarity index 55%
rename from net-misc/exabgp/exabgp-3.4.28.ebuild
rename to net-misc/exabgp/exabgp-3.4.28-r1.ebuild
index 81f8af7bae6786e739577b28b630503ae48244cb..c61d012c7a54b4de6a1e36c57dbdbd1d2daa66e9 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=7
 PYTHON_COMPAT=( python2_7 )
 DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
+inherit tmpfiles systemd distutils-r1
 
 DESCRIPTION="The BGP swiss army knife of networking"
 HOMEPAGE="https://github.com/Exa-Networks/exabgp"
@@ -17,3 +17,18 @@ KEYWORDS="~amd64"
 RDEPEND="
        dev-python/ipaddr[${PYTHON_USEDEP}]
 "
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+       newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+       newtmpfiles "${FILESDIR}/exabgp.tmpfiles" ${PN}.conf
+       systemd_dounit etc/systemd/*
+
+       insinto /etc/logrotate.d
+       newins "${FILESDIR}/${PN}.logrotate" ${PN}
+
+       keepdir /etc/exabgp
+}