net-print/cups-filters: Bump to version 1.27.4
authorLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 14:22:19 +0000 (16:22 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Sat, 11 Apr 2020 14:23:59 +0000 (16:23 +0200)
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.27.4.ebuild [new file with mode: 0644]

index 589863db56fe1e81d67adc4999b89052c9cacbef..e56b52ec0529f65ce12a20824c40b4482dbe6679 100644 (file)
@@ -3,3 +3,4 @@ DIST cups-filters-1.25.13.tar.xz 1485860 BLAKE2B 03fbbbefdd36e8f619fabf17e6e13d0
 DIST cups-filters-1.26.2.tar.xz 1490192 BLAKE2B 6bc5033c648e42a4590a941fd089c3bf3a901a36e26f12b3cdc892ea41943071903b2df2ef5730b7948270f4f59419083c9423af9482e032958360144fb04e9b SHA512 59a5eaba00e0f384f2b1498e58ea3d7272e42923a69eaa0c107ac103dc539c9bf14a94b7a91a73e7185d8a347b4ac7f4a7a655b1ffc373983da807c582e10264
 DIST cups-filters-1.27.1.tar.xz 1492256 BLAKE2B 30e4915bfc9a4f308defdcf13acc246330499008648edbce4df3efcf29fc960ac2c9a868ebe7cafcffb16b07763a2235ddd3d29a849ea18892b8da1d0f167775 SHA512 3fde635735138fa5ef511466b07f396f96860efcc51d9a01f5b95e86fc71ef48b9d17ba1bbe2eeb29585c3afc8bf26370b8f07df76a3adea2335be90e3fdb91b
 DIST cups-filters-1.27.2.tar.xz 1493220 BLAKE2B 4c767d114e59bc94a976056cbb5456464464a4226072b4448bc0de63cfb06b28023f4ef3857f6eee32bb2c1b13f9abc2b576557c6bb6328191af781ba3d680a6 SHA512 c0e1456dd3f512ae2215e566f853e47b66de46d0d1301fc5a6f3674ac7d1ddb03c3bb236b0419b20168742076381c58581cc3e582cf7abf76139367d549a6c46
+DIST cups-filters-1.27.4.tar.xz 1493860 BLAKE2B 424c3ba73ec7d6f4683eaedde86d657b1a2da17670c84097f5f3f8ef525cc8cc6d7843a88d35013a5f48bba8a903f7504df9054427b9a63d748ce39de458e71f SHA512 8005e94bb6b06d0a15fa4dfd8455d0bc67418478bf517e205af1c8c0018681a97ae9ea486db07570050ebeeb7f63f75319a8fe012c112c6d16c0941299eaa50e
diff --git a/net-print/cups-filters/cups-filters-1.27.4.ebuild b/net-print/cups-filters/cups-filters-1.27.4.ebuild
new file mode 100644 (file)
index 0000000..6cb600e
--- /dev/null
@@ -0,0 +1,138 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/gdbus-codegen
+       >=sys-devel/gettext-0.18.3
+       virtual/pkgconfig
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}