net-dialup/rp-pppoe: [QA] Fix UnnecessarySlashStrip
authorDavid Seifert <soap@gentoo.org>
Sat, 8 Feb 2020 16:22:47 +0000 (17:22 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 8 Feb 2020 16:22:47 +0000 (17:22 +0100)
Signed-off-by: David Seifert <soap@gentoo.org>
net-dialup/rp-pppoe/rp-pppoe-3.13.ebuild

index 2f775fca64a2ecbd2d436ba2a50fd3efb02846c8..ab0711a3d0de98b6025a7bf4d3b19e2d1338f078 100644 (file)
@@ -84,7 +84,7 @@ src_install () {
        emake DESTDIR="${D}" install #docdir=/usr/share/doc/${PF} install
 
        #Don't use compiled rp-pppoe plugin - see pkg_preinst below
-       local pppoe_plugin="${ED%/}/etc/ppp/plugins/rp-pppoe.so"
+       local pppoe_plugin="${ED}/etc/ppp/plugins/rp-pppoe.so"
        if [ -f "${pppoe_plugin}" ] ; then
                rm "${pppoe_plugin}" || die
        fi
@@ -105,7 +105,7 @@ src_install () {
 
 pkg_preinst() {
        # Use the rp-pppoe plugin that comes with net-dialup/pppd
-       if [ -n "${PPPD_VER}" ] && [ -f "${EROOT%/}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
+       if [ -n "${PPPD_VER}" ] && [ -f "${EROOT}/usr/lib/pppd/${PPPD_VER}/rp-pppoe.so" ] ; then
                dosym ../../../usr/lib/pppd/${PPPD_VER}/rp-pppoe.so /etc/ppp/plugins/rp-pppoe.so
        fi
 }