net-libs/libmicrohttpd: version bump to 0.9.62
authorAnthony G. Basile <blueness@gentoo.org>
Sun, 9 Dec 2018 13:08:54 +0000 (08:08 -0500)
committerAnthony G. Basile <blueness@gentoo.org>
Sun, 9 Dec 2018 13:08:54 +0000 (08:08 -0500)
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

net-libs/libmicrohttpd/Manifest
net-libs/libmicrohttpd/libmicrohttpd-0.9.62.ebuild [new file with mode: 0644]

index a8bd2e611e0b2c5a21930416fa6ff93e76ec5461..97cf15b26e66eddcda7b01423c2936e6b9eaf52f 100644 (file)
@@ -5,3 +5,4 @@ DIST libmicrohttpd-0.9.58.tar.gz 1333687 BLAKE2B ef3dfb4684f2c387399d9044eb46de7
 DIST libmicrohttpd-0.9.59.tar.gz 1396234 BLAKE2B 9cb2d52dd39bdc6c54267751e21a224ffa926f4200b392a28009c6f717b5059580884f4de1bb272f49f7c48bdae276df2832b413cc60db77222b7b1278ba6004 SHA512 2c9080ebd520631b5ab6eed42770c7911079365c7bc79ea74fc5502ebc370fdaea9a84a4d9db7cbd8ba1c4797c7531e127e3b73ad8d38601d700529f2bab84d5
 DIST libmicrohttpd-0.9.60.tar.gz 1818383 BLAKE2B 693da0a02e289000bb657d843cd577311e97ca4d8cd698d659410e669295314d429eb9679eedac98398420f3386c1fa6800c33b883481120ea199585412f8e83 SHA512 418afc302e93ac93141c2457c2bf03c6a1da4a16ff19aa655312f9953e1d0b132b0dd983fc36ccc703688b0acd68fc0900f5927efcada354a10078ba5e577325
 DIST libmicrohttpd-0.9.61.tar.gz 1823891 BLAKE2B d7704f36790b7f14e03a02b7fbc5eaaca5fc22702f1fadfc94f9fe05329505d5bf9422a1ff38daa1f33c82db3e1196a8db754227574cc2cb9441c08a50d65d72 SHA512 d409ca2164a55b0eab948a8a4a17e0d6547942039354f593b293a286a3cae247bd67d7de4ce0dd4f1a3f3684948250076f582a8086546eb72598a43d7f41a27d
+DIST libmicrohttpd-0.9.62.tar.gz 1837529 BLAKE2B eb06d6ee05af2b37909ad1c60e16de29d94278a7ffea6e7b98391330e3778950537f9c2d6b057186b4ed45af66853570c0a386b6e9b1f0164956bd0856ecbaa5 SHA512 337f29dbc5e8c30132c17aad6142f21ea1c794b0ce80a3fc4c5e1e14b3dabb300aa410bf9413ef9e65d5d486fcfedbc3716725763a1fa28b4687c9f2aa3158e4
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.62.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.62.ebuild
new file mode 100644 (file)
index 0000000..2c54b30
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+               dev-libs/libgcrypt:0=
+               net-libs/gnutls
+       )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+       test?   (
+               ssl? ( net-misc/curl[ssl] )
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" \
+       econf \
+               --enable-bauth \
+               --enable-dauth \
+               --disable-examples \
+               --enable-postprocessor \
+               --disable-thread-names \
+               $(use_enable epoll) \
+               $(use_enable test curl) \
+               $(use_enable messages) \
+               $(use_enable ssl https) \
+               $(use_with ssl gnutls) \
+               $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+       :
+}
+
+multilib_src_install_all() {
+       default
+
+       use static-libs || find "${ED}" -name '*.la' -delete
+}