dev-java/openjdk-jre-bin: bump to 11.0.7_p10
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 21 Apr 2020 17:42:02 +0000 (10:42 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Tue, 21 Apr 2020 20:26:25 +0000 (13:26 -0700)
Bug: https://bugs.gentoo.org/718720
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-java/openjdk-jre-bin/Manifest
dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.7_p10.ebuild [new file with mode: 0644]

index cb8c0d8268f0eaf4e7c02cb37e57becdcb7b6606..8aec8cb14aab49b987b68b6fadb49f177be7458e 100644 (file)
@@ -1,3 +1,4 @@
 DIST OpenJDK11U-jre_x64_linux_hotspot_11.0.6_10.tar.gz 42198347 BLAKE2B e0022f46f0f3de41d28baf19bcea2c7d6237e80586b7a1e3fb2b97aced18d564fe03a6706b8a3fe97375ff6be395aceafd1e0dba6adaddaa7285b0b8eb24310b SHA512 0d1366c68ad12fafc76edddc7d385f612751182b5492cff4309d542a0e12b13c9b17ca89a0a8218ad0f8182b24285189158c43759db54645758c7ea8dc4d6ce9
+DIST OpenJDK11U-jre_x64_linux_hotspot_11.0.7_10.tar.gz 42917723 BLAKE2B c5635b3727e10462396891cab89e257ded57c59f56e9bcb84a3d040ce8a27d7d67d6b78e5f55b63806dd93f6151b767df42e4428d12e763f9722196ca0736a08 SHA512 a776dd9168e3c2635a8492405d58628713e646292d7ee16454681d46866e7ea41afa712227e94ed2e8ce52c727e445f4631db63a02408aa817f1c79af8057dbe
 DIST OpenJDK8U-jre_x64_linux_hotspot_8u242b08.tar.gz 40987250 BLAKE2B ba3f15b938b4462a186c13ca8ea12c5e5e5bbfe5e716af1911e9525875e6956caf3155423f32433be05ebd1a3c873d94b33a797298d6d09577a775c7dfe2a658 SHA512 11dddf75813aa3b88b2bfb2ca89e186cc15601f75ec4f9cbe92c8b60f61438f75a76e45c26bc614eb54de16a584e906f8935cb2146937b96f2970eb89dddea09
 DIST OpenJDK8U-jre_x64_linux_hotspot_8u252b09.tar.gz 41104123 BLAKE2B 52a9f288054c4a96ed5d70c2c9c6cf14ceb32262ec3a38f547286518ccc14a4695d330adc19e272436c0a7154771cddd9b0672b05beb6d5013c44c69be0ad25a SHA512 b1b0627e8495b11e0ef3e4ecb387d92537bb97b3f3045213658d48b6f2dffa0bc975b1bc92e84c487152b43d1f0ee0449730bf84dd62d98d13354bf73d3a0a20
diff --git a/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.7_p10.ebuild b/dev-java/openjdk-jre-bin/openjdk-jre-bin-11.0.7_p10.ebuild
new file mode 100644 (file)
index 0000000..33938cb
--- /dev/null
@@ -0,0 +1,97 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2
+
+abi_uri() {
+       echo "${2-$1}? (
+                       https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jre_${1}_linux_hotspot_${MY_PV//+/_}.tar.gz
+               )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+       $(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt Java JRE binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64"
+IUSE="alsa cups +gentoo-vm headless-awt nsplugin selinux webstart"
+
+RDEPEND="
+       media-libs/fontconfig:1.0
+       media-libs/freetype:2
+       >net-libs/libnet-1.1
+       >=sys-apps/baselayout-java-0.1.0-r1
+       >=sys-libs/glibc-2.2.5:*
+       sys-libs/zlib
+       alsa? ( media-libs/alsa-lib )
+       cups? ( net-print/cups )
+       selinux? ( sec-policy/selinux-java )
+       !headless-awt? (
+               x11-libs/libX11
+               x11-libs/libXext
+               x11-libs/libXi
+               x11-libs/libXrender
+               x11-libs/libXtst
+       )"
+
+PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
+       nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}-jre"
+
+src_install() {
+       local dest="/opt/${P}"
+       local ddest="${ED%/}/${dest#/}"
+
+       # Not sure why they bundle this as it's commonly available and they
+       # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+       # also has an explicit dependency while Oracle seemingly dlopens it.
+       rm -vf lib/libfreetype.so || die
+
+       # Oracle and IcedTea have libjsoundalsa.so depending on
+       # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+       if ! use alsa ; then
+               rm -v lib/libjsound.* || die
+       fi
+
+       if use headless-awt ; then
+               rm -v lib/lib*{[jx]awt,splashscreen}* || die
+       fi
+
+       rm -v lib/security/cacerts || die
+       dosym ../../../../etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+       dodir "${dest}"
+       cp -pPR * "${ddest}" || die
+
+       use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+       java-vm_set-pax-markings "${ddest}"
+       java-vm_revdep-mask
+       java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+       java-vm-2_pkg_postinst
+
+       if use gentoo-vm ; then
+               ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JRE"
+               ewarn "recognised by the system. This will almost certainly break things."
+       else
+               ewarn "The experimental gentoo-vm USE flag has not been enabled so this JRE"
+               ewarn "will not be recognised by the system. For example, simply calling"
+               ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+               ewarn "fully supports Java 11. This JRE must therefore be invoked using its"
+               ewarn "absolute location under ${EPREFIX}/opt/${P}."
+       fi
+}