dev-libs/libpeas: fix python:3.8 compatibility
authorMart Raudsepp <leio@gentoo.org>
Sun, 16 Feb 2020 09:36:57 +0000 (11:36 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 16 Feb 2020 10:34:21 +0000 (12:34 +0200)
Looks like the addition of 3.8 to libpeas and almost all of its
consumers months ago was completely untested; fix it up in
straight-to-stable because all of those consumers already have
3.8 in their stable versions PYTHON_COMPAT.

Closes: https://bugs.gentoo.org/702810
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/libpeas/files/1.22.0-py38-support.patch [new file with mode: 0644]
dev-libs/libpeas/libpeas-1.22.0-r2.ebuild [moved from dev-libs/libpeas/libpeas-1.22.0-r1.ebuild with 93% similarity]

diff --git a/dev-libs/libpeas/files/1.22.0-py38-support.patch b/dev-libs/libpeas/files/1.22.0-py38-support.patch
new file mode 100644 (file)
index 0000000..6f4645d
--- /dev/null
@@ -0,0 +1,29 @@
+From 3571f4b23abbf5c63e38c82d24a1880fa440499e Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <mart@leio.tech>
+Date: Sat, 15 Feb 2020 23:23:09 +0200
+Subject: [PATCH] Fix python-3.8 compatibility
+
+---
+ configure.ac | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index bd561e2..d3d0073 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -442,7 +442,11 @@ else
+                 found_python3=yes
+                 PYTHON3_BIN="$PYTHON"
+                 PYTHON3_CFLAGS=`${PYTHON3_CONFIG} --includes`
+-                PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs`
++                if $PYTHON3_CONFIG --embed >/dev/null 2>&1; then
++                    PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs --embed`
++                else
++                    PYTHON3_LIBS=`${PYTHON3_CONFIG} --libs`
++                fi
+                 PYTHON3_LDFLAGS=`${PYTHON3_CONFIG} --ldflags`
+                 AC_SUBST(PYTHON3_BIN)
+                 AC_SUBST(PYTHON3_CFLAGS)
+-- 
+2.20.1
+
similarity index 93%
rename from dev-libs/libpeas/libpeas-1.22.0-r1.ebuild
rename to dev-libs/libpeas/libpeas-1.22.0-r2.ebuild
index d2eec7dc5313016484ff4bbc7a4f61d6e0eda573..9918e9e75b87e8ca7e3c82079675bc5e99e25d8e 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 GNOME2_LA_PUNT="yes"
+GNOME2_EAUTORECONF="yes"
 PYTHON_COMPAT=( python{3_6,3_7,3_8} )
 
 inherit autotools eutils gnome2 multilib python-single-r1 virtualx
@@ -44,17 +45,16 @@ DEPEND="${RDEPEND}
 "
 # eautoreconf needs gobject-introspection-common, gnome-common
 
+PATCHES=(
+       # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
+       "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
+       "${FILESDIR}"/${PV}-py38-support.patch # Fix py3.8 support, bug 702810
+)
+
 pkg_setup() {
        use python && python-single-r1_pkg_setup
 }
 
-src_prepare() {
-       # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
-       eapply "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
-       eautoreconf
-       gnome2_src_prepare
-}
-
 src_configure() {
        # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
        # What do we do about gdb, valgrind, gcov, etc?