app-backup/duplicity: Remove old (py2)
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 16:18:20 +0000 (17:18 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 16:27:46 +0000 (17:27 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-backup/duplicity/Manifest
app-backup/duplicity/duplicity-0.7.10.ebuild [deleted file]
app-backup/duplicity/duplicity-0.7.12.ebuild [deleted file]
app-backup/duplicity/duplicity-0.7.19.ebuild [deleted file]
app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch [deleted file]

index fe2a5ebc759919c93027b418faa424a769b7f4a3..315d66b58625ae7961afe430a53e18bc74ff06bb 100644 (file)
@@ -1,5 +1,2 @@
-DIST duplicity-0.7.10.tar.gz 1543523 BLAKE2B a38c5310d6949d36f74620ef617f790943284d7219168e0e49ed13834ab72f5c0d057ef59454e58a25be3a9e28d9627d60c007aab373e150afca08248d79aab6 SHA512 d04273384749c88d0a4f46bc1dcdcbb945ec1a78fb21064f12f0ca6c92cc73ad36fc3149461dbe0a660cd752a1147b2fa5d2b4056a5414c7790747eb5983e0bd
-DIST duplicity-0.7.12.tar.gz 1552442 BLAKE2B 4a7d0609748bffa147994a4abdb88bc0d62905c1423dc91caa4b8e5bb0c5953e26df72f647697685cfa3caed3741658d00d1a2b62b8c47bb1ac61da8973df9ca SHA512 8a532e7bb548c170184666a0ba2b41a15f3002c14edd64b1b1eb4df862647fc6dfde797d6ecf38e326d7c160c31ff521baf351e520835495e1d0e2ddbdb19f0f
-DIST duplicity-0.7.19.tar.gz 1727321 BLAKE2B 6441a2ce777b3b08c52ede8602a73080be372dec1c1788441c7e7135533aeeb3be48012db4bdfc2a78c7ca23d368637ccc7aa0f0361369ac9f42c00a1541e023 SHA512 26d1724a635c368e04f2a94f974ef6962c52b23345db59af3343e7221295caa0215ae119fff6ab44daa4622236683eb9d3dae742bf0d4cf08c02e3f63071001b
 DIST duplicity-0.8.09.tar.gz 1856764 BLAKE2B b5d0dd3270c237694000dc36a65a4293c43264edf933a195692d2847d008a898d5cf95c0b21b285503023ef8885278485cebabc2d2b7094ae65e13d277c80e5a SHA512 e4045a1c1adbf0927ee5325f02b79e7c0b38034080be4b563f20f1af593c8c1943a772fe7f212730e60f7c7cee93756426fe769a62050d42651fd1af7f6ba50a
 DIST duplicity-0.8.11.1596.tar.gz 1872223 BLAKE2B ad3ee2536731d1a6e8fb3fd87bb69b8ce8b43bb90688fe957cfb2718ad44f57db98c3aec4805356a7d44bea681f6ec9603aa082dbf86e58684fbe8000d1676b5 SHA512 67940d73d8213559ba88ec21e1326aca0dd065888cbf2e3c68f0f515ba9246100fd6e6d0bd1f12cb678702559f2266b7905931506d2ff6fe6fd35c673593479b
diff --git a/app-backup/duplicity/duplicity-0.7.10.ebuild b/app-backup/duplicity/duplicity-0.7.10.ebuild
deleted file mode 100644 (file)
index d686f7a..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="http://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="s3 test"
-
-CDEPEND="
-       net-libs/librsync
-       app-crypt/gnupg
-       dev-python/lockfile
-"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}
-       dev-python/paramiko[${PYTHON_USEDEP}]
-       s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       # workaround until failing test is fixed
-       local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
-
-       distutils-r1_python_prepare_all
-
-       sed -i "s/'COPYING',//" setup.py || die
-}
-
-python_test() {
-       esetup.py test
-}
-
-pkg_postinst() {
-       elog "Duplicity has many optional dependencies to support various backends."
-       elog "Currently it's up to you to install them as necessary."
-}
diff --git a/app-backup/duplicity/duplicity-0.7.12.ebuild b/app-backup/duplicity/duplicity-0.7.12.ebuild
deleted file mode 100644 (file)
index f23738b..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 versionator
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="http://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(get_version_component_range 1-2)-series/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="s3 test"
-
-CDEPEND="
-       net-libs/librsync
-       app-crypt/gnupg
-       dev-python/lockfile
-"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}
-       dev-python/paramiko[${PYTHON_USEDEP}]
-       s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       # workaround until failing test is fixed
-       local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
-
-       distutils-r1_python_prepare_all
-
-       sed -i "s/'COPYING',//" setup.py || die
-}
-
-python_test() {
-       esetup.py test
-}
-
-pkg_postinst() {
-       elog "Duplicity has many optional dependencies to support various backends."
-       elog "Currently it's up to you to install them as necessary."
-}
diff --git a/app-backup/duplicity/duplicity-0.7.19.ebuild b/app-backup/duplicity/duplicity-0.7.19.ebuild
deleted file mode 100644 (file)
index ba996e7..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Secure backup system using gnupg to encrypt data"
-HOMEPAGE="http://www.nongnu.org/duplicity/"
-SRC_URI="https://code.launchpad.net/${PN}/$(ver_cut 1-2)-series/${PV}/+download/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE="s3 test"
-
-CDEPEND="
-       net-libs/librsync
-       app-crypt/gnupg
-       dev-python/fasteners[${PYTHON_USEDEP}]
-"
-DEPEND="${CDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               app-arch/par2cmdline
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="${CDEPEND}
-       dev-python/paramiko[${PYTHON_USEDEP}]
-       s3? ( dev-python/boto[${PYTHON_USEDEP}] )
-"
-
-RESTRICT="!test? ( test )"
-
-python_prepare_all() {
-       # workaround until failing test is fixed
-       local PATCHES=( "${FILESDIR}"/${PN}-0.6.24-skip-test.patch )
-
-       distutils-r1_python_prepare_all
-
-       sed -i "s/'COPYING',//" setup.py || die
-}
-
-python_test() {
-       esetup.py test
-}
-
-pkg_postinst() {
-       elog "Duplicity has many optional dependencies to support various backends."
-       elog "Currently it's up to you to install them as necessary."
-}
diff --git a/app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch b/app-backup/duplicity/files/duplicity-0.6.24-skip-test.patch
deleted file mode 100644 (file)
index ef6d959..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- duplicity-0.6.24/testing/functional/test_final.py
-+++ duplicity-0.6.24/testing/functional/test_final.py
-@@ -156,6 +156,7 @@
-         self.run_duplicity(options=["remove-older-than", "50000", "--force", self.backend_url])
-         self.assertEqual(self.get_backend_files(), second_chain)
-+    @unittest.skip('skip failing test')
-     def test_piped_password(self):
-         """Make sure that prompting for a password works"""
-         self.set_environ("PASSPHRASE", None)