x11-terms/kitty: bump to 0.17.4
authorend222 <pabloorduna98@gmail.com>
Sat, 9 May 2020 09:06:55 +0000 (11:06 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 17 May 2020 08:40:31 +0000 (11:40 +0300)
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15722
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
x11-terms/kitty/Manifest
x11-terms/kitty/kitty-0.17.4.ebuild [new file with mode: 0644]

index bac5a972e96ef54ca02579c9727e03fe7cf72bda..a441c39bf253ddb66c2863838bc5b3ef74bf99db 100644 (file)
@@ -1,2 +1,3 @@
 DIST kitty-0.17.2.tar.xz 3044140 BLAKE2B 12dcb8ddb7d90a22904f575301e8c2b1672c3212ee29a035fa5e8eec553dafb0e2c8c1cc3a491c8ac6854d619e979e518d83c5218f36647a032a4f847d068ef3 SHA512 bccf1c1d60d1149bc5f849b82db1af80a2d9a7a11c5f2df853daae5700550eef98da389a30f015d67be796f39deacb31f3ee245eb37ba1a41ba377c70cd26d61
 DIST kitty-0.17.3.tar.xz 3064216 BLAKE2B f5ab532d97c211ceed463c24758635a9e7168bf03990889a98ebdad7fc8c1c60f5f3726724007f00ac6a5f5e8db44ca54a4a43027dbf6ce1fdfcaa40c7b8e10c SHA512 dc14ba35e77e0ebd1978fde0731b00e726e75137f900952dfa6b06add1f46e3a3f42e8e886ce8c689e4e3500f2d2216a66225d5211522a41d09ef61265065e2d
+DIST kitty-0.17.4.tar.xz 3068456 BLAKE2B 7c3be1bd9e1be814ca2c98ac8bed5c8ac906021efee9e399bddb8d1f2d6faa4368f08741fd24666892272c5ffc68e62d490f3a3b20a4f1cb1025401741ace29f SHA512 4ea954a59f44b04a1540d814892b08c93e37c07d7dd32b5db3f50806fa6f39a8a89957c216e47b43bf7aa9571dd0200de7dc12266cc672c9e70e39b2133da0d7
diff --git a/x11-terms/kitty/kitty-0.17.4.ebuild b/x11-terms/kitty/kitty-0.17.4.ebuild
new file mode 100644 (file)
index 0000000..24b1011
--- /dev/null
@@ -0,0 +1,104 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       ${PYTHON_DEPS}
+       media-libs/fontconfig
+       media-libs/freetype:2
+       >=media-libs/harfbuzz-1.5.0:=
+       media-libs/libcanberra
+       media-libs/libpng:0=
+       sys-apps/dbus
+       sys-libs/zlib
+       x11-libs/libxcb[xkb]
+       x11-libs/libXcursor
+       x11-libs/libXi
+       x11-libs/libXinerama
+       x11-libs/libxkbcommon[X]
+       x11-libs/libXrandr
+       x11-terms/kitty-terminfo
+       wayland? (
+               dev-libs/wayland
+               >=dev-libs/wayland-protocols-1.17
+       )
+       $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_MULTI_USEDEP}]' python3_6)
+"
+
+DEPEND="${RDEPEND}
+       media-libs/mesa[X(+)]
+       sys-libs/ncurses
+"
+
+BDEPEND="virtual/pkgconfig"
+
+[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.17.2-flags.patch
+       "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
+       "${FILESDIR}"/${PN}-0.16.0-remove-terminfo.patch
+)
+
+src_prepare() {
+       default
+
+       # disable wayland as required
+       if ! use wayland; then
+               sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+       fi
+
+       # respect doc dir
+       sed -i "/htmldir =/s/appname/'${PF}'/" setup.py || die
+
+       tc-export CC
+}
+
+src_compile() {
+       "${EPYTHON}" setup.py \
+               --verbose $(usex debug --debug "") \
+               --libdir-name $(get_libdir) \
+               linux-package || die "Failed to compile kitty."
+}
+
+src_test() {
+       export KITTY_CONFIG_DIRECTORY=${T}
+       "${EPYTHON}" test.py || die
+}
+
+src_install() {
+       insinto /usr
+       doins -r linux-package/*
+       dobin linux-package/bin/kitty
+       python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+       optfeature "Displaying images in the terminal" virtual/imagemagick-tools
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}