dev-libs/libgit2: Bump to 1.0.0
authorMichał Górny <mgorny@gentoo.org>
Thu, 2 Apr 2020 06:27:31 +0000 (08:27 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 2 Apr 2020 06:49:51 +0000 (08:49 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/libgit2/Manifest
dev-libs/libgit2/libgit2-1.0.0.ebuild [new file with mode: 0644]

index 65b412e39e1fe0f2b0b0d15c0590834c375f643c..0e8c90c9ea90caabe68c6ff51be18ba76df0e232 100644 (file)
@@ -1,3 +1,4 @@
 DIST libgit2-0.28.4.tar.gz 4991720 BLAKE2B 7dc94dce69c27f6de3736b94b4d80b727e3e2a7db255a9eab7422cebd93a3ea1a6f47d1de6c3fbe4ba5bcb28ade9b23a989c5b54c06eafeaf30e382f3b859cdf SHA512 b81160608003b25d9b922d259ebbbbf941b6bd5100fa1875497c8cd29de320e292fff568c757a7a85b2b3044ddc1cb92c74dbcb13d630d62ecf9a8559b619d15
 DIST libgit2-0.28.5.tar.gz 4998481 BLAKE2B 71a3502af125a3d1c91700539d5e235a62922b32ca5e62288581b496f4cb680c01bfe70ae092ab730fc45df1dd96c2c9167f51d551a50acd57c857b4ea07634d SHA512 abfea885f46444b0304ae57c32c06f4252afb0093c924da5e1ba10aaed952824d1b84036adb79b5b8ad8bea56a6331a51c62f3b9839aead16c7b26cb4554b53a
 DIST libgit2-0.99.0.tar.gz 5307975 BLAKE2B 2ff6c48d29844c8efd292b636c018403f49ae5eef1ef41e2c8755cc35d935677fa965b52c05724aa133f8542a266bb0e0fabb34fcf710127332bd6137ea4ff12 SHA512 e38e18da0e6ed1e5c8198c9eb2c362b21da2d0b9c8bc23309d2f70183549f4b9f23a6db8ce5f1f0f24b373e6427039c2a845b62dd74f91b02cfe8954f961a91b
+DIST libgit2-1.0.0.tar.gz 5312324 BLAKE2B 4106b934d32233e9df8a405570a83c3b7ab097e3301dc973230df511f992733e237e1fdc48924522b16a6d202dc4e81461f522e0f5fd867c9f3ad261921af3ba SHA512 7e3b6582dd1567fd5ebfc829a98e22acfd5566ba08f2fb9b7a6783fa87f5e8952ac67f1a2c13adb543e56753d858e73a03204bac17a096c72f5daf4ba376d904
diff --git a/dev-libs/libgit2/libgit2-1.0.0.ebuild b/dev-libs/libgit2/libgit2-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..bd8e71f
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit cmake python-any-r1
+
+DESCRIPTION="A linkable library for Git"
+HOMEPAGE="https://libgit2.org"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P/_/-}
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0/0.99"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="examples gssapi libressl +ssh test +threads trace"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       sys-libs/zlib
+       net-libs/http-parser:=
+       gssapi? ( virtual/krb5 )
+       ssh? ( net-libs/libssh2 )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       cmake_src_prepare
+       # relying on forked http-parser to support some obscure URI form
+       sed -i -e '/empty_port/s:test:_&:' tests/network/urlparse.c || die
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_CLAR=$(usex test)
+               -DENABLE_TRACE=$(usex trace ON OFF)
+               -DUSE_GSSAPI=$(usex gssapi ON OFF)
+               -DUSE_SSH=$(usex ssh)
+               -DTHREADSAFE=$(usex threads)
+               -DUSE_HTTP_PARSER=system
+       )
+       cmake_src_configure
+}
+
+src_test() {
+       if [[ ${EUID} -eq 0 ]] ; then
+               # repo::iterator::fs_preserves_error fails if run as root
+               # since root can still access dirs with 0000 perms
+               ewarn "Skipping tests: non-root privileges are required for all tests to pass"
+       else
+               local TEST_VERBOSE=1
+               cmake_src_test -R offline
+       fi
+}
+
+src_install() {
+       cmake_src_install
+       dodoc docs/*.{md,txt}
+
+       if use examples ; then
+               find examples -name '.gitignore' -delete || die
+               dodoc -r examples
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
+}