app-arch/funzix: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Fri, 29 Dec 2017 11:20:46 +0000 (12:20 +0100)
committerDavid Seifert <soap@gentoo.org>
Fri, 29 Dec 2017 13:15:53 +0000 (14:15 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-arch/funzix/files/funzix-1.0-fix-build-system.patch [new file with mode: 0644]
app-arch/funzix/funzix-1.0.ebuild

diff --git a/app-arch/funzix/files/funzix-1.0-fix-build-system.patch b/app-arch/funzix/files/funzix-1.0-fix-build-system.patch
new file mode 100644 (file)
index 0000000..1fd5482
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,4 +1,4 @@
+-CFLAGS += -Wall -g
++CFLAGS += -Wall
+ LDLIBS += -lz
+ all: funzix
index 9d479a6c8eff7e93f35c1832608980a29e4af085..8f62fd7801f6e0c99ede6877ce0942401b53b957 100644 (file)
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
+EAPI=6
+
 inherit toolchain-funcs
 
 DESCRIPTION="unpacker for the bogus ZIX format"
@@ -12,11 +14,13 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
-src_compile() {
-       emake CC="$(tc-getCC)" || die "emake failed"
+PATCHES=( "${FILESDIR}"/${PN}-1.0-fix-build-system.patch )
+
+src_configure() {
+       tc-export CC
 }
 
 src_install() {
-       dobin funzix || die
-       dodoc README
+       dobin funzix
+       einstalldocs
 }