games-misc/katawa-shoujo: Update to EAPI 7
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>
Sun, 10 Nov 2019 16:35:11 +0000 (11:35 -0500)
committerJames Le Cuirot <chewi@gentoo.org>
Wed, 13 Nov 2019 18:45:00 +0000 (18:45 +0000)
The system-renpy USE flag is removed since system dependencies should
be used rather than those bundled in the package.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13601
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-misc/katawa-shoujo/Manifest
games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild [deleted file]
games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r2.ebuild [new file with mode: 0644]
games-misc/katawa-shoujo/metadata.xml

index bca40183149823467b5525e4122a181faf175739..8e49bf1e084020387a0264b95e368614c4068d55 100644 (file)
@@ -1,3 +1 @@
 DIST katawa-shoujo-1.3.1.tar.bz2 496188604 BLAKE2B a27fbc84ac0594790ad5b77e6c7e49c19c2b4716b1e5e516171b593211f1d5f2ca1bddc3e0ebb92420b7529b4b2fdff7b0732bb61b5aa2acdaf45e33dd713497 SHA512 d5f1b49c60b70b272dd5d62c1d49cb9e3c17e3f77339fc593db2122f1c140005bc23ecb7ad9b0d93c0701c77f9bcfcd5c1c67db1cbe3034a3be42a4309387809
-DIST katawa-shoujo-256.png 59803 BLAKE2B 2acf08b55ae3e776ac260b552fd6a04b17a3246534702fbf39bdfcd49348778c1703d0ad135bca7933a82de3d983b9c19c255ed72006b7ca2c73acc157f6e9cb SHA512 7d920c24f4182ba72d5b3d641d7d373c166ca4c7d0b6a396f5e3b9281cb43f7e6e8e761f2f181ff061705118b3080807866fcd290d2b471e98c3a584d5fa8e0e
-DIST katawa-shoujo-48.png 3621 BLAKE2B 1f9ad61bcbd90218d6b11269e7c93a5b2816eee0640f191027e656978dc968a673a3ff02deee0d960a188c2893dde95a45134a847c58c627e1fd7ff2e5b28da1 SHA512 ad24156cf446ffe92068baaa6d512e6bab90587db5ce01b3c18e6c42bb9b8c91f7eae3e9547099d3f8f0a5d3f144676c3499c0a38d9af845abf79e153b543bef
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r1.ebuild
deleted file mode 100644 (file)
index aa8f03e..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils gnome2-utils
-
-DESCRIPTION="Bishoujo-style visual novel by Four Leaf Studios"
-HOMEPAGE="https://www.katawa-shoujo.com"
-SRC_URI="https://dl.katawa-shoujo.com/gold_1.3.1/%5B4ls%5D_katawa_shoujo_1.3.1-%5Blinux-x86%5D%5B18161880%5D.tar.bz2 -> ${P}.tar.bz2
-       https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-48.png
-       https://dev.gentoo.org/~hasufell/distfiles/katawa-shoujo-256.png"
-
-# bundled renpy includes licenses of all libraries
-LICENSE="
-       CC-BY-NC-ND-3.0
-       !system-renpy? ( MIT PSF-2 LGPL-2.1 || ( FTL GPL-2+ ) IJG libpng ZLIB BZIP2 )
-"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="doc +system-renpy"
-REQUIRED_USE="!system-renpy? ( || ( amd64 x86 ) )"
-
-RDEPEND="system-renpy? ( games-engines/renpy:6.99 )"
-DEPEND=""
-
-# Binaries are built extremely weirdly, resulting in errors like:
-# BFD: Not enough room for program headers, try linking with -N
-#
-# Technically, we could make this unconditional because there are no other
-# binaries, but it's still good practice.
-RESTRICT="!system-renpy? ( strip )"
-
-QA_PREBUILT="/opt/${PN}/lib/*"
-
-S="${WORKDIR}/Katawa Shoujo-${PV}-linux"
-
-src_install() {
-       if use system-renpy; then
-               insinto "/usr/share/${PN}"
-               doins -r game/.
-               make_wrapper ${PN} "renpy '/usr/share/${PN}'"
-       else
-               insinto "/opt/${PN}"
-               doins -r game localizations renpy "Katawa Shoujo."{py,sh}
-
-               local host="${CTARGET:-${CHOST}}"
-               local arch="${host%%-*}"
-
-               cd lib
-               insinto "/opt/${PN}/lib"
-               doins -r linux-${arch} pythonlib2.7
-               cd ..
-
-               fperms +x "/opt/${PN}/lib/linux-${arch}/"{python,"Katawa Shoujo"} \
-                       "/opt/${PN}/Katawa Shoujo."{py,sh}
-
-               make_wrapper ${PN} "./Katawa\ Shoujo.sh" "/opt/${PN}"
-       fi
-
-       local i
-       for i in 48 256; do
-               newicon -s ${i} "${DISTDIR}"/${PN}-${i}.png ${PN}.png
-       done
-
-       make_desktop_entry ${PN} "Katawa Shoujo"
-
-       if use doc; then
-               dodoc "Game Manual.pdf"
-       fi
-}
-
-pkg_preinst() {
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}
diff --git a/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r2.ebuild b/games-misc/katawa-shoujo/katawa-shoujo-1.3.1-r2.ebuild
new file mode 100644 (file)
index 0000000..2ab5b56
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils desktop
+
+RENPY_SLOT="6.99"
+
+DESCRIPTION="Bishoujo-style visual novel by Four Leaf Studios"
+HOMEPAGE="https://www.katawa-shoujo.com"
+SRC_URI="https://dl.katawa-shoujo.com/gold_${PV}/%5B4ls%5D_katawa_shoujo_${PV}-%5Blinux-x86%5D%5B18161880%5D.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="CC-BY-NC-ND-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/Katawa Shoujo-${PV}-linux"
+
+src_install() {
+       insinto "/usr/share/${PN}"
+       doins -r game/.
+       make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+
+       make_desktop_entry ${PN} "Katawa Shoujo" applications-games
+
+       if use doc; then
+               dodoc "Game Manual.pdf"
+       fi
+}
index 7dd3491164248a6932c317473f274601273f1ad8..e1f782e395f7ac2ce558ea3cca862bd391fa49a3 100644 (file)
@@ -5,9 +5,6 @@
                <email>games@gentoo.org</email>
                <name>Gentoo Games Project</name>
        </maintainer>
-       <use>
-               <flag name="system-renpy">Use <pkg>games-engines/renpy</pkg> instead of the bundled one (experimental)</flag>
-       </use>
        <longdescription>
                Katawa Shoujo is a bishoujo-style visual novel set in the fictional
                Yamaku High School for disabled children, located somewhere in modern