app-benchmarks/geekbench: drop fetch and strip restriction
authorConrad Kostecki <conrad@kostecki.com>
Fri, 25 Oct 2019 15:52:16 +0000 (17:52 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 29 Oct 2019 06:19:10 +0000 (08:19 +0200)
After talking to Upstream,
it's fine, that the drop the fetch and strip restriction.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Closes: https://github.com/gentoo/gentoo/pull/13433
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-benchmarks/geekbench/geekbench-2.4.2.ebuild
app-benchmarks/geekbench/geekbench-2.4.3.ebuild
app-benchmarks/geekbench/geekbench-3.4.2.ebuild
app-benchmarks/geekbench/geekbench-4.4.1.ebuild

index c8df4703ddb8b404290b4b23ee0a29c9da0c3238..72a97542161ab8bbadb4ddd7a9ddee41445ceb39 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -11,7 +11,7 @@ KEYWORDS="-* arm"
 LICENSE="geekbench"
 SLOT="2"
 
-RESTRICT="bindist fetch mirror strip"
+RESTRICT="bindist mirror"
 
 S="${WORKDIR}/dist/Geekbench-${PV}-LinuxARM"
 
@@ -23,14 +23,14 @@ pkg_nofetch() {
 }
 
 src_install() {
-       exeinto "/opt/geekbench2"
-       doexe "geekbench" "geekbench_arm_32"
+       exeinto /opt/geekbench2
+       doexe geekbench geekbench_arm_32
 
-       insinto "/opt/geekbench2"
-       doins "geekbench.plar"
+       insinto /opt/geekbench2
+       doins geekbench.plar
 
-       dodir "/opt/bin"
-       dosym "../geekbench2/geekbench" "/opt/bin/geekbench2"
+       dodir /opt/bin
+       dosym ../geekbench2/geekbench /opt/bin/geekbench2
 }
 
 pkg_postinst() {
index 44d63ccf38c070b657e87b73fb26a8e29a766bfc..cb416e92c5c50b2bb37633a9b43ca282a893fafe 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -11,7 +11,7 @@ KEYWORDS="-* amd64 x86"
 LICENSE="geekbench"
 SLOT="2"
 
-RESTRICT="bindist fetch mirror strip"
+RESTRICT="bindist mirror"
 
 S="${WORKDIR}/dist/Geekbench-${PV}-Linux"
 
@@ -23,14 +23,14 @@ pkg_nofetch() {
 }
 
 src_install() {
-       exeinto "/opt/geekbench2"
-       doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"
+       exeinto /opt/geekbench2
+       doexe geekbench geekbench_x86_32 geekbench_x86_64
 
-       insinto "/opt/geekbench2"
-       doins "geekbench.plar"
+       insinto /opt/geekbench2
+       doins geekbench.plar
 
-       dodir "/opt/bin"
-       dosym "../geekbench2/geekbench" "/opt/bin/geekbench2"
+       dodir /opt/bin
+       dosym ../geekbench2/geekbench /opt/bin/geekbench2
 }
 
 pkg_postinst() {
index 5994b8d352e1da5da8d36a1840343715147ddc87..7b396a012b925c7d0dfb9ee02394497eb463bb2b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -11,7 +11,7 @@ KEYWORDS="-* amd64 x86"
 LICENSE="geekbench"
 SLOT="3"
 
-RESTRICT="bindist fetch mirror strip"
+RESTRICT="bindist mirror"
 
 S="${WORKDIR}/dist/Geekbench-${PV}-Linux"
 
@@ -23,14 +23,14 @@ pkg_nofetch() {
 }
 
 src_install() {
-       exeinto "/opt/geekbench3"
-       doexe "geekbench" "geekbench_x86_32" "geekbench_x86_64"
+       exeinto /opt/geekbench3
+       doexe geekbench geekbench_x86_32 geekbench_x86_64
 
-       insinto "/opt/geekbench3"
-       doins "geekbench.plar"
+       insinto /opt/geekbench3
+       doins geekbench.plar
 
-       dodir "/opt/bin"
-       dosym "../geekbench3/geekbench" "/opt/bin/geekbench3"
+       dodir /opt/bin
+       dosym ../geekbench3/geekbench /opt/bin/geekbench3
 }
 
 pkg_postinst() {
index 6768181dccfdcf76a499a4de08dab29cb764def2..cde1b3d69e923564e1c61501c7ba308abd716544 100644 (file)
@@ -11,7 +11,7 @@ KEYWORDS="-* amd64 x86"
 LICENSE="geekbench"
 SLOT="4"
 
-RESTRICT="bindist fetch mirror strip"
+RESTRICT="bindist mirror"
 
 S="${WORKDIR}/Geekbench-${PV}-Linux"