games-rpg/zsdx: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 17:55:43 +0000 (19:55 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 1 May 2018 19:35:34 +0000 (21:35 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-rpg/zsdx/zsdx-1.9.0-r1.ebuild [new file with mode: 0644]

diff --git a/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild b/games-rpg/zsdx/zsdx-1.9.0-r1.ebuild
new file mode 100644 (file)
index 0000000..dc00fda
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils gnome2-utils
+
+DESCRIPTION="A free 2D Zelda fangame"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="all-rights-reserved CC-BY-SA-3.0 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="
+       >=games-engines/solarus-1.3.0
+       <games-engines/solarus-1.4.0
+"
+DEPEND="app-arch/zip"
+
+src_configure() {
+       local mycmakeargs=(
+               -DSOLARUS_INSTALL_DATAROOTDIR="/usr/share"
+               -DSOLARUS_INSTALL_BINDIR="/usr/bin"
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       newicon -s 48 build/icons/${PN}_icon_48.png ${PN}.png
+       newicon -s 256 build/icons/${PN}_icon_256.png ${PN}.png
+
+       # install proper wrapper script
+       rm -f "${ED}"/usr/bin/${PN}
+       make_wrapper ${PN} "solarus \"/usr/share/solarus/${PN}\""
+
+       make_desktop_entry "${PN}" "Zelda: Mystery of Solarus DX"
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}