dev-embedded/libjaylink: add a snapshot from git so we can add openocd 0.10.0
authorZero_Chaos <zerochaos@gentoo.org>
Tue, 24 Jan 2017 21:40:43 +0000 (16:40 -0500)
committerZero_Chaos <zerochaos@gentoo.org>
Tue, 24 Jan 2017 21:53:59 +0000 (16:53 -0500)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-embedded/libjaylink/Manifest [new file with mode: 0644]
dev-embedded/libjaylink/libjaylink-0.1.0.ebuild [new file with mode: 0644]

diff --git a/dev-embedded/libjaylink/Manifest b/dev-embedded/libjaylink/Manifest
new file mode 100644 (file)
index 0000000..5aa3e02
--- /dev/null
@@ -0,0 +1 @@
+DIST libjaylink-0.1.0.tar.xz 53820 SHA256 df7d27b78a5c800c1a26f83d1d723f9d30e4c3122c760fe062e9b451606a1516 SHA512 9031da29adb703b771cb049d76bec5033b6885321d8ac411984ac800224677f9b201c92553d150450c4a6898826c06189ee4fdc1048430edaef89704e31ec21a WHIRLPOOL 1a7716f98bfb8772f24db746251155a4ba7f0072448ca9db44a07b0f07f31c1eb2c32d724a648f6f742980e40d1e2ccc5b5b2d808cd16800359e2a9112f4c0b2
diff --git a/dev-embedded/libjaylink/libjaylink-0.1.0.ebuild b/dev-embedded/libjaylink/libjaylink-0.1.0.ebuild
new file mode 100644 (file)
index 0000000..0e4374a
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit autotools eutils
+
+DESCRIPTION="Library to access J-Link devices"
+HOMEPAGE="http://git.zapb.de/libjaylink.git"
+
+SRC_URI="https://dev.gentoo.org/~zerochaos/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+DEPEND="virtual/libusb:1"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       eapply_user
+       eautoreconf || die
+}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       default
+       prune_libtool_files
+}