dev-libs/cgilib: Drop autotools-utils.eclass
authorJeroen Roovers <jer@gentoo.org>
Fri, 2 Nov 2018 11:48:00 +0000 (12:48 +0100)
committerJeroen Roovers <jer@gentoo.org>
Fri, 2 Nov 2018 14:33:52 +0000 (15:33 +0100)
Package-Manager: Portage-2.3.51, Repoman-2.3.11
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/cgilib/cgilib-0.7-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/cgilib/cgilib-0.7-r1.ebuild b/dev-libs/cgilib/cgilib-0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..1f29ddd
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A simple and lightweight interface to the CGI for C and C++ programs"
+HOMEPAGE="http://www.infodrom.org/projects/cgilib/"
+SRC_URI="${HOMEPAGE}download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+DOCS=( AUTHORS ChangeLog README cookies.txt )
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static)
+}