games-strategy/freeorion: Add missing PYTHON_*
authorMichał Górny <mgorny@gentoo.org>
Mon, 12 Aug 2019 19:55:04 +0000 (21:55 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 12 Aug 2019 19:55:04 +0000 (21:55 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
games-strategy/freeorion/freeorion-0.4.7.1-r4.ebuild
games-strategy/freeorion/freeorion-0.4.8_p20190501.ebuild
games-strategy/freeorion/freeorion-9999.ebuild

index e3471161e466e74e3dd10398fe61a16b50da6b97..e827e00ef9ecb930e2ca8a9b4792badb09fbabf3 100644 (file)
@@ -23,6 +23,8 @@ LICENSE="GPL-2 LGPL-2.1 CC-BY-SA-3.0"
 SLOT="0"
 IUSE=""
 
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
 RDEPEND="
        >=dev-libs/boost-1.56:=[python,threads,${PYTHON_USEDEP}]
        media-libs/freealut
@@ -37,11 +39,11 @@ RDEPEND="
        sci-physics/bullet
        sys-libs/zlib
        virtual/opengl
+       ${PYTHON_DEPS}
        !dev-games/gigi"
        # Use bundled gigi as of freeorion-0.4.3
 
 DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
        virtual/pkgconfig"
 
 PATCHES=( "${FILESDIR}/${P}-backport-sdl2-include-dir-fix.patch" )
index 2c29c8b5c266aa86173979f79930949389dfb80f..3aea6bd3b5d95aae80c38cfb39abd7f8bdd9ab8d 100644 (file)
@@ -48,10 +48,9 @@ RDEPEND="
                virtual/opengl
        )
        sys-libs/zlib
-"
-DEPEND="${RDEPEND}
        ${PYTHON_DEPS}
 "
+DEPEND="${RDEPEND}"
 
 pkg_setup() {
        # build system is using FindPythonLibs.cmake which needs python:2
index 2c29c8b5c266aa86173979f79930949389dfb80f..3aea6bd3b5d95aae80c38cfb39abd7f8bdd9ab8d 100644 (file)
@@ -48,10 +48,9 @@ RDEPEND="
                virtual/opengl
        )
        sys-libs/zlib
-"
-DEPEND="${RDEPEND}
        ${PYTHON_DEPS}
 "
+DEPEND="${RDEPEND}"
 
 pkg_setup() {
        # build system is using FindPythonLibs.cmake which needs python:2