pp-emulation/ganeti-instance-debootstrap: revbump (EAPI=7)
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 22 Jul 2019 13:28:19 +0000 (16:28 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 22 Jul 2019 13:29:15 +0000 (16:29 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild [new file with mode: 0644]

diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.11-r1.ebuild
new file mode 100644 (file)
index 0000000..1a4184f
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://www.ganeti.org/"
+SRC_URI="https://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+       app-arch/dump
+       app-emulation/ganeti
+       dev-util/debootstrap
+       >=sys-apps/coreutils-6.10-r1
+       sys-apps/util-linux
+       sys-fs/e2fsprogs"
+
+src_configure() {
+       econf --docdir=/usr/share/doc/${P}
+}
+
+src_install() {
+       default
+       insinto /etc/ganeti/instance-debootstrap/hooks
+       doins examples/hooks/*
+}