net-mail/smtptools: Fix building with CFLAGS=-fno-common
authorJeroen Roovers <jer@gentoo.org>
Thu, 28 May 2020 08:58:01 +0000 (10:58 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 28 May 2020 08:58:51 +0000 (10:58 +0200)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Closes: https://bugs.gentoo.org/707142
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-mail/smtptools/files/smtptools-0.2.3-cleanups.patch
net-mail/smtptools/files/smtptools-0.2.3-fno-common.patch [new file with mode: 0644]
net-mail/smtptools/smtptools-0.2.3-r1.ebuild [new file with mode: 0644]

index 6873cf3902554a5967d15c9a64f3b8badcb90568..3ea1d43712a021d60fac21efab78eb741c9f4db8 100644 (file)
@@ -1,5 +1,5 @@
---- smtptools/usmtpd.c
-+++ smtptools/usmtpd.c
+--- a/usmtpd.c
++++ b/usmtpd.c
 @@ -60,8 +60,8 @@
  /* run */ static const char *reminfo;
  /* run */ static const char *relayclient;
  
        if (rblcheck) do_rbl_check(&o);
  
---- smtptools/relaydb.c
-+++ smtptools/relaydb.c
+--- a/relaydb.c
++++ b/relaydb.c
 @@ -1,4 +1,5 @@
  #include "config.h"
 +#include <string.h>
  #include <unistd.h>
  #include <netinet/in.h>
  #include <arpa/inet.h>
---- smtptools/uostr.h
-+++ smtptools/uostr.h
+--- a/uostr.h
++++ b/uostr.h
 @@ -1,6 +1,7 @@
  #ifndef UOSTR_H
  #define UOSTR_H
diff --git a/net-mail/smtptools/files/smtptools-0.2.3-fno-common.patch b/net-mail/smtptools/files/smtptools-0.2.3-fno-common.patch
new file mode 100644 (file)
index 0000000..34435ec
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/uostr.h
++++ b/uostr.h
+@@ -14,7 +14,7 @@
+ uostr_t *uostr_alloc P__((void)); /* mallocs a uostr_t and inits with 0 */
+ void uostr_free P__((uostr_t *)); /* free(uostr_t), after free(uostr_t->data) */
+ void uostr_freedata P__((uostr_t *)); /* free(uostr_t->data) */
+-void (*uostr_xallocfn) P__((const char *)); /* called by x-functions in case of oom */
++extern void (*uostr_xallocfn) P__((const char *)); /* called by x-functions in case of oom */
+ void uostr_xallocerr P__((const char *fn)) UO_ATTRIB_NORET; /* internal function, leave alone */
+ /* be careful - if u->data is NULL then u->len and u->size need not to contain any information */
diff --git a/net-mail/smtptools/smtptools-0.2.3-r1.ebuild b/net-mail/smtptools/smtptools-0.2.3-r1.ebuild
new file mode 100644 (file)
index 0000000..4c93c71
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A collection of tools to send or receive mails with SMTP"
+HOMEPAGE="https://www.ohse.de/uwe/software/smtptools.html"
+SRC_URI="ftp://ftp.ohse.de/uwe/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+RDEPEND="!net-mail/qtools"
+PATCHES=(
+       "${FILESDIR}"/${P}-cleanups.patch
+       "${FILESDIR}"/${P}-fno-common.patch
+)
+
+src_prepare() {
+       eapply "${FILESDIR}"/${P}-autotools.patch
+       mv configure.{in,ac} || die
+       rm acconfig.h || die
+
+       default
+       eautoreconf
+}