games-util/lgogdownloader: version bump to 3.3
authorsoredake <fdsfgs@krutt.org>
Thu, 9 Nov 2017 10:00:59 +0000 (12:00 +0200)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 9 Nov 2017 20:16:24 +0000 (20:16 +0000)
Closes: https://github.com/gentoo/gentoo/pull/6149

games-util/lgogdownloader/Manifest
games-util/lgogdownloader/lgogdownloader-3.3.ebuild [new file with mode: 0644]

index 2daae536192adee04001dcca35c7d8b835f44c12..4646701f32568f9e080d40951d799127e2af23c9 100644 (file)
@@ -1 +1,2 @@
 DIST lgogdownloader-3.2.tar.gz 68438 SHA256 9e60af50c18533884ca317778b291152d5f04d93dfd3dc2579f6f965538b2031 SHA512 b1d8d89b303c77e17601b19e09346b8d632bc049d40741442ad88646d8764e4efd3a04edcbcae5a5e098df3251ae88d15d355d06cbb03cf313a8619d3111ff35 WHIRLPOOL f584c1e86d0e867b54d5e3415bcd0403baf783a9feb3d2ed3024c3dbfbe0892ddbf3dc79c535d8692570a8fe9dcab0cace38032ba255d805adb3fd300af3f79a
+DIST lgogdownloader-3.3.tar.gz 73873 SHA256 8bb7a37b48f558bddeb662ebac32796b0ae11fa2cc57a03d48b3944198e800ce SHA512 7af67c440e88bcfbbd6f59b44b8cfd81fe9cee041715d4da968be3aedfe4301a5377ce61354a5cc093588d89300c88c862d9228672a2d79613419dce3619f4c9 WHIRLPOOL 3f497a8e606490016e6a30d7ac83d5f734c5290f206e34d6de2ea844d81fb2002e1601194a7c37fbf6e271467f834c2ce0c60daaea8c9343a632300a020ae828
diff --git a/games-util/lgogdownloader/lgogdownloader-3.3.ebuild b/games-util/lgogdownloader/lgogdownloader-3.3.ebuild
new file mode 100644 (file)
index 0000000..0ac33ea
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+       dev-cpp/htmlcxx:0=
+       dev-libs/boost:0=
+       >=dev-libs/jsoncpp-1.7:0=
+       dev-libs/tinyxml2:0=
+       net-libs/liboauth:0=
+       >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+       sys-apps/help2man
+       virtual/pkgconfig"