app-emacs/xrdb-mode: Fix old-style backquotes.
authorUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 17:13:27 +0000 (19:13 +0200)
committerUlrich Müller <ulm@gentoo.org>
Sun, 10 May 2020 17:13:53 +0000 (19:13 +0200)
Closes: https://bugs.gentoo.org/722170
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/xrdb-mode/files/xrdb-mode-3.0-backquotes.patch [new file with mode: 0644]
app-emacs/xrdb-mode/xrdb-mode-3.0-r1.ebuild [new file with mode: 0644]

diff --git a/app-emacs/xrdb-mode/files/xrdb-mode-3.0-backquotes.patch b/app-emacs/xrdb-mode/files/xrdb-mode-3.0-backquotes.patch
new file mode 100644 (file)
index 0000000..f0cd950
--- /dev/null
@@ -0,0 +1,15 @@
+--- a/xrdb-mode.el
++++ b/xrdb-mode.el
+@@ -178,9 +178,9 @@
+ (defmacro xrdb-safe (&rest body)
+   "Safely execute BODY, return nil if an error occurred."
+-  (` (condition-case nil
+-         (progn (,@ body))
+-       (error nil))))
++  `(condition-case nil
++       (progn ,@ body)
++     (error nil)))
+ (defsubst xrdb-skip-to-separator ()
+   "Skip forward.
diff --git a/app-emacs/xrdb-mode/xrdb-mode-3.0-r1.ebuild b/app-emacs/xrdb-mode/xrdb-mode-3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..9f78792
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing X resource database files"
+HOMEPAGE="https://launchpad.net/xrdb-mode
+       https://www.emacswiki.org/emacs/ResourceFiles"
+# taken from https://launchpad.net/${PN}/trunk/3.0/+download/${PN}.el
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+PATCHES=("${FILESDIR}"/${P}-backquotes.patch)
+SITEFILE="50${PN}-gentoo.el"