app-laptop/mbpfan: bump to 2.0.1
authorGöktürk Yüksek <gokturk@gentoo.org>
Wed, 23 Aug 2017 18:39:52 +0000 (14:39 -0400)
committerGöktürk Yüksek <gokturk@gentoo.org>
Wed, 23 Aug 2017 18:43:31 +0000 (14:43 -0400)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

app-laptop/mbpfan/Manifest
app-laptop/mbpfan/mbpfan-2.0.1.ebuild [new file with mode: 0644]

index fc220df4e44cbf034a0da194ac5f57310812f401..bb3508a9d2e3577f357d5d8700a7d7a44bfb8fd4 100644 (file)
@@ -1,2 +1,3 @@
 DIST mbpfan-1.9.1.tar.gz 24393 SHA256 a7cf850a393ebfce21427b992436b84cc4b20e1cb8d673d45d2c8b991c69e68c SHA512 04f1f70697ccd182c329588623c6664979e1cc25db8a39a2ea9f6d1ec49f3914172c3ada392fabc9ac51a811f36087dc600426c34c201d02a5d7b791b04f0f3b WHIRLPOOL a97cc5eb8ebb25353e5fe7b86854daf52bfa99b6ad3a490ef3006fdd9162b8c96840692d1939071e4404438535e4f44f0a5b41cc5cb43b115046fe4b3fd89a8a
 DIST mbpfan-2.0.0.tar.gz 37912 SHA256 4e8874c7302b8d237faa8bf706acf5bf0ea8ec4ebff2debfc9717bca7d9ea15b SHA512 9a7f930afe0a151fe50bf3ef1a06a5cecaced0c47f7088a83b91e25dff85d4b0d53494eac5eb1b624bde6ff1d3307a0d9fe6ba392fdacbe58e241d93d11cda6d WHIRLPOOL 051406f3dafc0aecfc0d1afac1e10d9f2a0d9b2a8ddde12282b767b007e1211b88f8e5d48f03d7b46bd5e6b0a9d17088c7011364d16f0b3f09bbafd1bbe552c9
+DIST mbpfan-2.0.1.tar.gz 37805 SHA256 72bc27fc3dfb4c01c1c476ae74084fc66c7a1039057a7c73441606981adfa311 SHA512 8fd2e37b9b81720ff7efa490d285da5980ef5dcc858fef4b0c24166a8f0df46aa230ea18fca5775b222271918e5ca6df1bfbbdced068182c20eeb86192ed2019 WHIRLPOOL dd7c98f7cf6fe84d40c4c070d3daa1640641c971659632bd3778eed24b319f30aa308728b8ee1026a03d8a6f8f9de01eabd8182727263da10779cc097e68cbcc
diff --git a/app-laptop/mbpfan/mbpfan-2.0.1.ebuild b/app-laptop/mbpfan/mbpfan-2.0.1.ebuild
new file mode 100644 (file)
index 0000000..357bf95
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+if [[ "${PV}" = 9999 ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}
+
+src_install() {
+       emake DESTDIR="${ED}" install
+
+       # Remove the empty systemd unit directory
+       # It doesn't actually install the unit file
+       rmdir --ignore-fail-on-non-empty -p "${ED%/}/lib/systemd/system" || die
+       # Actually install the sytstemd unit file
+       systemd_dounit ${PN}.service
+       # Install openrc init file
+       newinitd ${PN}.init.gentoo ${PN}
+
+       # make install doesn't install the docs in the right place
+       rm -rf "${ED%/}/usr/share/doc/${PN}" || die
+
+       einstalldocs
+}