x11-terms/terminator: bump version, support py3
authorAlexey Sokolov <sokolov@google.com>
Tue, 3 Mar 2020 01:08:52 +0000 (01:08 +0000)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 30 Apr 2020 23:18:40 +0000 (16:18 -0700)
Some notes:

* I replaced gnome2 with xdg because gnome2 doesn't work with EAPI 7. I
  don't know whether the rest of things gnome2 eclass did is important.
* I put myself to maintainer because Andreas Sturmlechner told me to.

It seems to work, and the test passes.

Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alexey Sokolov <sokolov@google.com>
Closes: https://bugs.gentoo.org/716446
Closes: https://github.com/gentoo/gentoo/pull/14826
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
x11-terms/terminator/Manifest
x11-terms/terminator/files/terminator-1.91-without-icon-cache.patch [new file with mode: 0644]
x11-terms/terminator/metadata.xml
x11-terms/terminator/terminator-1.92.ebuild [new file with mode: 0644]

index 28305643e3a77265cc004c21597128c3ea7df4d9..5de1326fab2293e5191ea348c84959999af86886 100644 (file)
@@ -1 +1,2 @@
 DIST terminator-1.91.tar.gz 910536 BLAKE2B 887eef489dc3eb73f7ae8f6284104ee5e6a23b33bc8486b203f9b53c7de5a11a43fdc6a344b02f269c0d4ce71cfc82f0c8285440900870870a43cd10d99326b9 SHA512 6feee96cda08f913601d3b01e51632bed87712ddb5ce577df1daa8a5fe4e8dc39075d5e21f87b865d1f007c7e1070ee2c0c814540c9c7786f0f24fbee762a03d
+DIST terminator-1.92.tar.gz 910613 BLAKE2B d7a665f81011b21da14837492f04204158e95d846aaf876d2393fe4a236113d9718be9b3946f38e1385168bbcec72fd65b895b5f476727c8a67bbc6e51016a63 SHA512 9a63d1993582d94711b7be6cad0ecde3969b3a5d297ab388677b485161fae308a93d559f84bc4cb7ff71c8755cac6c2511b3677a8ab1da3da6427c53c68529f1
diff --git a/x11-terms/terminator/files/terminator-1.91-without-icon-cache.patch b/x11-terms/terminator/files/terminator-1.91-without-icon-cache.patch
new file mode 100644 (file)
index 0000000..c924de3
--- /dev/null
@@ -0,0 +1,16 @@
+Without this patch, terminator's build script runs gtk-update-icon-cache which
+causes terminator package to claim /usr/share/icons/hicolor/icon-theme.cache as
+its own. To avoid that, gtk-update-icon-cache is run later, as part of
+xdg_pkg_postinst in the ebuild.
+
+--- a/setup.py 2009-08-12 22:22:53.000000000 -0400
++++ b/setup.py 2009-08-12 22:22:57.000000000 -0400
+@@ -25,7 +25,7 @@
+   def __init__ (self, *args):
+     self.without_gettext = False
+-    self.without_icon_cache = False
++    self.without_icon_cache = True
+     Distribution.__init__(self, *args)
index 44b22d322ad33c20dc0c9b92e15c7315e4485df2..d11068fa01fd6bc7b85e75f5b3f6069629f7f9ad 100644 (file)
@@ -2,8 +2,12 @@
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
        <maintainer type="person">
-               <email>chutzpah@gentoo.org</email>
-               <name>Patrick McLean</name>
+               <email>alexey+gentoo@asokolov.org</email>
+               <name>Alexey Sokolov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
        </maintainer>
        <longdescription>
                Much of the behaviour of Terminator is based on GNOME Terminal, and
@@ -16,6 +20,6 @@
                <flag name="libnotify">Enables desktop notifications via<pkg>dev-python/notify-python</pkg></flag>
        </use>
        <upstream>
-               <remote-id type="launchpad">terminator</remote-id>
+               <remote-id type="github">gnome-terminator/terminator</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/x11-terms/terminator/terminator-1.92.ebuild b/x11-terms/terminator/terminator-1.92.ebuild
new file mode 100644 (file)
index 0000000..64edc13
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Multiple GNOME terminals in one window"
+HOMEPAGE="https://github.com/gnome-terminator/terminator"
+SRC_URI="https://github.com/gnome-terminator/terminator/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus +libnotify test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/glib-2.32:2
+       dev-libs/keybinder:3[introspection]
+       dev-python/configobj[${PYTHON_USEDEP}]
+       dev-python/psutil[${PYTHON_USEDEP}]
+       dev-python/pycairo[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       >=x11-libs/gtk+-3.16:3
+       x11-libs/vte:2.91[introspection]
+       dbus? ( sys-apps/dbus )
+       libnotify? ( x11-libs/libnotify[introspection] )
+"
+BDEPEND="
+       dev-util/intltool
+       test? ( ${RDEPEND} )
+"
+
+PATCHES=(
+       "${FILESDIR}"/terminator-1.91-without-icon-cache.patch
+       "${FILESDIR}"/terminator-1.91-desktop.patch
+)
+
+src_prepare() {
+       xdg_environment_reset
+       distutils-r1_src_prepare
+}
+
+python_test() {
+       virtx esetup.py test || die "tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+}