app-office/dia: EAPI-6 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 12:39:19 +0000 (14:39 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 30 Apr 2020 15:10:07 +0000 (17:10 +0200)
Acked-by: Mart Raudsepp <leio@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-office/dia/dia-0.97.3-r1.ebuild
app-office/dia/files/dia-0.97.2-underlinking.patch

index f697cd004baf657e084a3465434fd05a2281b81d..fc0207a5f053c09fdb093cdac2de9237df7fec0e 100644 (file)
@@ -1,11 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-GCONF_DEBUG=yes
-GNOME2_LA_PUNT=yes
+EAPI=6
 
-inherit autotools eutils gnome2 multilib
+GNOME2_EAUTORECONF="yes"
+inherit gnome2
 
 DESCRIPTION="Diagram/flowchart creation program"
 HOMEPAGE="https://wiki.gnome.org/Apps/Dia"
@@ -40,13 +39,15 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        doc? ( dev-libs/libxslt )"
 
-src_prepare() {
-       DOCS="AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO"
+DOCS=( AUTHORS ChangeLog KNOWN_BUGS MAINTAINERS NEWS README RELEASE-PROCESS THANKS TODO )
 
-       epatch "${FILESDIR}"/${PN}-0.97.0-gnome-doc.patch #159381 , upstream #470812 #558690
-       epatch "${FILESDIR}"/${PN}-0.97.2-underlinking.patch #420685, upstream #678761
-       epatch "${FILESDIR}"/${PN}-0.97.3-freetype_pkgconfig.patch #654814, upstream https://gitlab.gnome.org/GNOME/dia/merge_requests/1
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.97.0-gnome-doc.patch #159381 , upstream #470812 #558690
+       "${FILESDIR}"/${PN}-0.97.2-underlinking.patch #420685, upstream #678761
+       "${FILESDIR}"/${PN}-0.97.3-freetype_pkgconfig.patch #654814, upstream https://gitlab.gnome.org/GNOME/dia/merge_requests/1
+)
 
+src_prepare() {
        if ! use doc; then
                # Skip man generation
                sed -i -e '/if HAVE_DB2MAN/,/endif/d' doc/*/Makefile.am || die
index 903e077f23f4f29bc9c369a5b96846b418ceaa37..297888cc9b6ec790ca2afafb5564125ed3e4568c 100644 (file)
@@ -6,13 +6,13 @@ Subject: [PATCH] Fix missing linkage with gmodule-2.0.
 Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=678761
 Fixes: https://bugs.gentoo.org/show_bug.cgi?id=420685
 ---
dia-0.97.2/configure.in | 2 +-
+ configure.in | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/dia-0.97.2/configure.in b/dia-0.97.2/configure.in
+diff --git a/configure.in b/configure.in
 index 72830de..6b7394a 100644
---- a/dia-0.97.2/configure.in
-+++ b/dia-0.97.2/configure.in
+--- a/configure.in
++++ b/configure.in
 @@ -55,7 +55,7 @@ AC_SUBST(GMODULE_CFLAGS)
  AC_SUBST(GMODULE_LIBS)
  AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)