x11-terms/alacritty: fix build failing with python3.9
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 29 May 2020 23:17:15 +0000 (16:17 -0700)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Fri, 29 May 2020 23:17:43 +0000 (16:17 -0700)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
x11-terms/alacritty/alacritty-0.4.3_rc1.ebuild

index 00fdbc4f355bd17c76c8dce302b40dab0070f160..e6af50acba76a7e79ef194a81b1aeb188b3ec4c3 100644 (file)
@@ -267,8 +267,10 @@ zip-0.5.5
 "
 
 MY_PV="${PV//_rc/-rc}"
+# https://bugs.gentoo.org/725962
+PYTHON_COMPAT=( python3_{7,8} )
 
-inherit bash-completion-r1 cargo desktop
+inherit bash-completion-r1 cargo desktop python-any-r1
 
 DESCRIPTION="GPU-accelerated terminal emulator"
 HOMEPAGE="https://github.com/alacritty/alacritty"
@@ -288,7 +290,7 @@ IUSE="wayland +X"
 
 REQUIRED_USE="|| ( wayland X )"
 
-DEPEND="
+DEPEND="${PYTHON_DEPS}
        media-libs/fontconfig:=
        media-libs/freetype:2
        X? ( x11-libs/libxcb:=[xkb] )