app-laptop/tp_smapi: remove "unused" tp_smapi-0.42-r1.ebuild.
authorMichael Orlitzky <mjo@gentoo.org>
Sat, 2 Mar 2019 21:33:40 +0000 (16:33 -0500)
committerMichael Orlitzky <mjo@gentoo.org>
Sat, 2 Mar 2019 21:35:11 +0000 (16:35 -0500)
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

app-laptop/tp_smapi/Manifest
app-laptop/tp_smapi/tp_smapi-0.42-r1.ebuild [deleted file]

index d2f981db017dd352e31614b321867aba4bc70bd5..86ff549068b9e2ecb90132d085b0b5df40efcd55 100644 (file)
@@ -1,2 +1 @@
-DIST tp_smapi-0.42.tgz 39867 BLAKE2B 0f7285fe99766437d964780f3c9d88480a19ed07de155e1794b5c48f318846fbde4eb759e825af9f5da89fb20aee5e217f32e873a70c7d85f63e3a44b385b0f7 SHA512 1004b7ef961a9908c2144b26ea60b6dddabd83d60c11421a03e3b810f5b635415ef52656d6980915512d68f809f7bc3d662328f25d111537bd7e175d252cf83b
 DIST tp_smapi-0.43.tgz 40122 BLAKE2B e14caa05d741d14b03c56c57badc5900a47735bc58966b5195ca34269a6227ecc50518ee5ce8cf47a4aacb314a0ed0332b987098f3be024b6af9024df6efdf9b SHA512 ec2e40a248e7eb5bff2ad9e57087058a8b4706d564bd340daba5a4700ad8a5389d1f9ec29984516a1167827ae55c28240dafb558df29e1f758a4f7af80caa1e7
diff --git a/app-laptop/tp_smapi/tp_smapi-0.42-r1.ebuild b/app-laptop/tp_smapi/tp_smapi-0.42-r1.ebuild
deleted file mode 100644 (file)
index a7aa315..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic linux-mod
-
-DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
-HOMEPAGE="https://github.com/evgeni/${PN}"
-SRC_URI="${HOMEPAGE}/releases/download/tp-smapi/${PV}/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-IUSE="hdaps"
-
-# We need dmideode if the kernel does not support
-# DMI_DEV_TYPE_OEM_STRING in dmi.h.
-DEPEND="sys-apps/dmidecode"
-RDEPEND="${DEPEND}"
-
-# This code is factored out of both pkg_pretend() and pkg_setup()
-# because the PMS states that ebuilds may not call phase functions
-# directly (see the "List of functions" section). This was bug #596616
-# and #596622.
-tp_smapi_pkg_pretend() {
-       linux-mod_pkg_setup
-
-       MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
-       BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_OUT_DIR}"
-       BUILD_TARGETS="default"
-
-       if use hdaps; then
-               CONFIG_CHECK="~INPUT_UINPUT"
-               WARNING_INPUT_UINPUT="Your kernel needs uinput for the hdaps module to perform better"
-               # Why call this twice?
-               linux-info_pkg_setup
-
-               MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
-               BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
-
-               CONFIG_CHECK="~!SENSORS_HDAPS"
-               ERROR_SENSORS_HDAPS="${P} with USE=hdaps conflicts with in-kernel HDAPS (CONFIG_SENSORS_HDAPS)"
-               linux-info_pkg_setup
-       fi
-}
-
-pkg_pretend() {
-       tp_smapi_pkg_pretend
-}
-
-pkg_setup() {
-       # run again as pkg_pretend is not var safe
-       tp_smapi_pkg_pretend
-}
-
-src_compile() {
-       # Kernel Makefiles may pull in -mpreferred-stack-boundary=3
-       # which requires that SSE disabled or compilation will fail.
-       # So we need to ensure that appended user CLAGS do not re-enable SSE
-       # https://bugs.gentoo.org/show_bug.cgi?id=492964
-       replace-flags '-msse*' ''
-       replace-flags '-mssse3' ''
-
-       linux-mod_src_compile
-}
-
-src_install() {
-       linux-mod_src_install
-       einstalldocs
-       newinitd "${FILESDIR}/${PN}-0.40-initd" smapi
-       newconfd "${FILESDIR}/${PN}-0.40-confd" smapi
-}