dev-libs/libevdev: Version bump to 1.9.0
authorMatt Turner <mattst88@gentoo.org>
Wed, 4 Mar 2020 19:58:29 +0000 (11:58 -0800)
committerMatt Turner <mattst88@gentoo.org>
Wed, 4 Mar 2020 20:44:53 +0000 (12:44 -0800)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
dev-libs/libevdev/Manifest
dev-libs/libevdev/libevdev-1.9.0.ebuild [new file with mode: 0644]

index 194c585471d82db04b04559bc0e35f80a27c789a..67e4a1a246319891871d1c91b5254d5df879b8e0 100644 (file)
@@ -1 +1,2 @@
 DIST libevdev-1.8.0.tar.xz 439000 BLAKE2B 408c60669557419c945901da5f146302cf0cdc43ed74cf4dc8ff4a9c272319c49f644bf95acf3d8656173bfc2f3763a6cc172ee4707a7f0129d15449701e9449 SHA512 8d285632f4fe87c01e81f94e514bec4e37fed4bc44d6d38b9297dba1114e42f6ed8d143fc05f3d0e8d51b08b659e34481dc4c65f60421c54e2f3e11efbafdeb4
+DIST libevdev-1.9.0.tar.xz 443208 BLAKE2B 858567ec82f20d567f66d0c41bd1519ffd023a0374e346cff270a0bae0b5136a469a4fd56fcbd3d53b2a2ace6166821ec5e75c90e08eb347331e7974865ceda7 SHA512 6e7589b5776437ac23fbf65b3194fb1dd3a68a294696145060cdd97bcdeb9b04f355f2be028dc1a5efe98ef2cafca15e4f61115edf5d62591e3a8944dc95942a
diff --git a/dev-libs/libevdev/libevdev-1.9.0.ebuild b/dev-libs/libevdev/libevdev-1.9.0.ebuild
new file mode 100644 (file)
index 0000000..c975e20
--- /dev/null
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit meson multilib-minimal python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+       EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+       inherit git-r3
+else
+       SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+       ${PYTHON_DEPS}
+       doc? ( app-doc/doxygen )
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_feature doc documentation)
+               $(meson_feature test tests)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       meson_src_test
+}
+
+multilib_src_install() {
+       meson_src_install
+}
+
+multilib_src_install_all() {
+       if use doc; then
+               local HTML_DOCS=( doc/html/. )
+               einstalldocs
+       fi
+}