app-cdr/cdemu-daemon: Bump to 3.2.4
authorMichał Górny <mgorny@gentoo.org>
Tue, 7 Jan 2020 05:42:06 +0000 (06:42 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 7 Jan 2020 06:02:06 +0000 (07:02 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-cdr/cdemu-daemon/Manifest
app-cdr/cdemu-daemon/cdemu-daemon-3.2.4.ebuild [new file with mode: 0644]

index fc9bce6ed690aab867cd2dd65e75d733bf7dec30..29f3b77c17dcfcb1aba93d8419db31f7f1ecd929 100644 (file)
@@ -1 +1,2 @@
 DIST cdemu-daemon-3.2.3.tar.bz2 83130 BLAKE2B 2be64beb662ebeb51d75a34bccece5f5eede8abe447d4d0be60bf1bbe4e1f9ac6eeaa67783f763f4966571cf4e13fb9b61610ead40d8a13842400f48bb3b1618 SHA512 a1c7fdea9e32e71591a29de98f28dd4d2d0ffb972861916ab287ff33f5f070da8fcc113b602e4b02fd08a72f7361ae85440ef5eb156e312a849cd716207026a7
+DIST cdemu-daemon-3.2.4.tar.bz2 83580 BLAKE2B 56cfde3b9b9a98ba0da629deac717a740b7c92c67195ac282af5337f0e782b555f53221741a59abf3e78faacd066e34a722d08e27cef6fd1082cb75b46eb3ace SHA512 b5dd19a9325773e22c1910ae02f351803fb4f02197eaf5d41a984b4898a5fb0f027c70791d4c25553a9b589273fa3578d3cb12aa7a056f8639b341bd2ab44291
diff --git a/app-cdr/cdemu-daemon/cdemu-daemon-3.2.4.ebuild b/app-cdr/cdemu-daemon/cdemu-daemon-3.2.4.ebuild
new file mode 100644 (file)
index 0000000..788bf66
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils
+
+DESCRIPTION="Daemon of the CDEmu optical media image mounting suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/cdemu-daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/7" # subslot = CDEMU_DAEMON_INTERFACE_VERSION_MAJOR in CMakeLists.txt
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.38:2
+       >=dev-libs/libmirage-3.2.0:=
+       >=media-libs/libao-0.8.0:="
+RDEPEND="${DEPEND}
+       sys-apps/dbus
+       >=sys-fs/vhba-20130607"
+BDEPEND="
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS README )
+
+pkg_postinst() {
+       elog "You will need to load the vhba module to use cdemu devices:"
+       elog " # modprobe vhba"
+       elog "To automatically load the vhba module at boot time, edit your"
+       elog "/etc/conf.d/modules file."
+
+       if [[ -e ${ROOT}/etc/conf.d/cdemud ]]; then
+               elog
+               elog "${PN} no longer installs an init.d service; instead, it is"
+               elog "automatically activated when needed via dbus."
+               elog "You can therefore remove ${ROOT}/etc/conf.d/cdemud"
+       fi
+}