dev-php/composer: bump to v1.9.0
authorThomas Deutschmann <whissi@gentoo.org>
Sat, 17 Aug 2019 23:20:04 +0000 (01:20 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 17 Aug 2019 23:37:02 +0000 (01:37 +0200)
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/composer/Manifest
dev-php/composer/composer-1.9.0.ebuild [new file with mode: 0644]

index 7b7890d9a3dac34b5bc4e98b4834b972445f9236..7495d665940255fbff5a75c9b33b951dc5d92dbf 100644 (file)
@@ -1 +1,2 @@
 DIST composer-1.8.6.tar.gz 409002 BLAKE2B 15d9621e062646b81518aff816a3e0b187bf1d9cd617c32e3a19167ba0c89b9ee8f55503e7d2e6d3515939f7d50131c5be0786fc04518409584960290eb32118 SHA512 97ab93acba24307897fe64b3762e77ebca9fa794c5eb476a9d774feb124dbd53b090c36b0fa9d1da38ea26d13af8bf13d7bc733c9c465fba6b908e590ea96dbc
+DIST composer-1.9.0.tar.gz 410267 BLAKE2B 5bbba9eefe703eb55a7d63647e8ecb3e4560b4ffeff321282f4f0c0db1aca143e210b517f98cf5fd9a9839d714b9badb1092b9d1430d65f29e5b134d9321370f SHA512 70e484404752a6b4aa94dc2c5999ab615c5518b60a580399096c7d2b0a026feadc7c10509a00920eab8f0298015fb1f5f82abc426927a35b8bc3c3e454d0b20e
diff --git a/dev-php/composer/composer-1.9.0.ebuild b/dev-php/composer/composer-1.9.0.ebuild
new file mode 100644 (file)
index 0000000..d39d576
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Dependency Manager for PHP"
+HOMEPAGE="https://github.com/composer/composer"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-lang/php:*[curl]
+       >=dev-php/ca-bundle-1.1.3
+       >=dev-php/psr-log-1.1.0
+       dev-php/fedora-autoloader
+       >=dev-php/json-schema-5.2.7
+       >=dev-php/jsonlint-1.7.1
+       >=dev-php/phar-utils-1.0.1
+       >=dev-php/semver-1.4.2
+       >=dev-php/spdx-licenses-1.5.0
+       >=dev-php/symfony-console-2.8.48
+       >=dev-php/symfony-filesystem-2.8.48
+       >=dev-php/symfony-finder-2.8.49
+       >=dev-php/symfony-process-2.8.48
+       >=dev-php/xdebug-handler-1.3.1"
+
+src_install() {
+       insinto "/usr/share/${PN}"
+
+       # Composer expects the LICENSE file to be there, and the
+       # easiest thing to do is to give it what it wants.
+       doins -r src res LICENSE
+
+       insinto "/usr/share/${PN}/vendor"
+       newins "${FILESDIR}"/autoload-r1.php autoload.php
+
+       exeinto "/usr/share/${PN}/bin"
+       doexe "bin/${PN}"
+       dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+       dodoc CHANGELOG.md README.md doc/*.md
+       dodoc -r doc/articles doc/faqs
+}