x11-misc/birdtray: update XDG icon cache
authorMarek Szuba <marecki@gentoo.org>
Fri, 17 Apr 2020 21:59:55 +0000 (22:59 +0100)
committerMarek Szuba <marecki@gentoo.org>
Fri, 17 Apr 2020 22:18:34 +0000 (23:18 +0100)
Signed-off-by: Marek Szuba <marecki@gentoo.org>
x11-misc/birdtray/birdtray-1.7.0.ebuild
x11-misc/birdtray/birdtray-9999.ebuild

index a3777b79577c39a41981051029f66423a7125fc6..27005bff4ede4c17d618978c1eedd8dc9a497359 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake
+inherit cmake xdg-utils
 
 DESCRIPTION="A new mail system tray notification icon for Thunderbird"
 HOMEPAGE="https://github.com/gyunaev/birdtray"
@@ -29,3 +29,11 @@ RDEPEND="dev-db/sqlite:=
        x11-libs/libX11"
 
 DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}
index a3777b79577c39a41981051029f66423a7125fc6..27005bff4ede4c17d618978c1eedd8dc9a497359 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit cmake
+inherit cmake xdg-utils
 
 DESCRIPTION="A new mail system tray notification icon for Thunderbird"
 HOMEPAGE="https://github.com/gyunaev/birdtray"
@@ -29,3 +29,11 @@ RDEPEND="dev-db/sqlite:=
        x11-libs/libX11"
 
 DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}