games-action/apotheon: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 21:45:41 +0000 (22:45 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 8 Jun 2019 21:45:41 +0000 (22:45 +0100)
I unbundled theoraplay as a new package but decided not to package
mojoshader as it is not versioned and the ABI seems quite volatile.

Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-action/apotheon/Manifest [new file with mode: 0644]
games-action/apotheon/apotheon-1.26v.ebuild [new file with mode: 0644]
games-action/apotheon/metadata.xml [new file with mode: 0644]

diff --git a/games-action/apotheon/Manifest b/games-action/apotheon/Manifest
new file mode 100644 (file)
index 0000000..96e2716
--- /dev/null
@@ -0,0 +1 @@
+DIST apotheon-12302015-bin 623626343 BLAKE2B 31b9bc8d05ff5709fdf54b0df790dad3f6eda3510516aa2837d3d53bb4e708b460debd45eab3899beee33b6d11ec385699b650bb55439be784b97959ce23cd65 SHA512 099dee0c7006ce1c977e55796be867ff02a2001e5f1d897d84203b52aae52c7e7cdba2eeb47452181ef2a2b044b315af87b5b87632e9ff2f7047b262f1a0a11d
diff --git a/games-action/apotheon/apotheon-1.26v.ebuild b/games-action/apotheon/apotheon-1.26v.ebuild
new file mode 100644 (file)
index 0000000..96c00bc
--- /dev/null
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop unpacker xdg-utils
+
+DESCRIPTION="Heroic action game set within the vibrant world of Ancient Greek Mythology"
+HOMEPAGE="https://www.apotheongame.com"
+SRC_URI="${PN}-12302015-bin"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="bindist fetch splitdebug"
+
+RDEPEND="
+       dev-lang/mono
+       media-libs/libsdl2[joystick,opengl,threads,video]
+       media-libs/openal
+       media-libs/sdl2-image
+       media-libs/theoraplay
+"
+
+S="${WORKDIR}/data"
+
+DIR="/opt/${PN}"
+QA_PREBUILT="${DIR}/*"
+
+pkg_nofetch() {
+       einfo "Please buy and download ${SRC_URI} from:"
+       einfo "  https://www.humblebundle.com/store/${PN}"
+       einfo "and move it to your distfiles directory."
+}
+
+src_unpack() {
+       unpack_zip ${A}
+}
+
+src_install() {
+       local \
+               EXE=Apotheon.bin.$(usex amd64 x86_64 x86) \
+               LIB=lib$(usex amd64 64 "")
+
+       exeinto "${DIR}"
+       doexe ${EXE}
+       dosym "${DIR}"/${EXE} /usr/bin/${PN}
+
+       insinto "${DIR}"
+       doins -r Content/ Dialog/ *.exe [A-LP]*.dll* # Exclude some Mono DLLs.
+
+       exeinto "${DIR}"/${LIB}
+       doexe ${LIB}/libmojo*
+
+       dodoc Linux.README
+
+       newicon -s 512 Apotheon.png ${PN}.png
+       make_desktop_entry ${PN} "Apotheon"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/games-action/apotheon/metadata.xml b/games-action/apotheon/metadata.xml
new file mode 100644 (file)
index 0000000..26079e6
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+</pkgmetadata>