app-backup/snapper: version bump, 0.8.7
authorYixun Lan <dlan@gentoo.org>
Fri, 17 Apr 2020 15:15:28 +0000 (23:15 +0800)
committerYixun Lan <dlan@gentoo.org>
Fri, 17 Apr 2020 15:17:35 +0000 (23:17 +0800)
create /etc/snapper/configs to fix bug #717126

Closes: https://bugs.gentoo.org/717126
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Yixun Lan <dlan@gentoo.org>
app-backup/snapper/Manifest
app-backup/snapper/snapper-0.8.7.ebuild [new file with mode: 0644]

index bc65a1d4748cc15d8d15bef4b389cac1d0bcb9cc..ccb8ef15eec06bcf55f1a39b658c6884f0f3282d 100644 (file)
@@ -2,3 +2,4 @@ DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee
 DIST snapper-0.8.4.tar.bz2 594555 BLAKE2B b176420be06dea2dca73fafbebb362bb27d9b793868f84466dae020cea9d1c61c7a3896de6e0701d1e924eed8c13b1b11a7bbc3047ca41c9aaee260a438ddce3 SHA512 9e3708a2b015470798731e105ab843f21c5273f0f2f4e183afde538ad4998892c4d79996e1963e74d0a09d10b9b3057faed5e2f501a1d9a5a4b1fa36ba88bb7e
 DIST snapper-0.8.5.tar.bz2 595516 BLAKE2B 4cf59fa5098f91281bae98476b30c21532df5035ee7ed66fd07e279174bd5da902e1e5af845ab92f217146a6c420620ff464c9705fd06b430bbf3566aa9ae484 SHA512 496b09f4878cbc82c791f35467735e321fdcbd2bc478fac918394b9f6718b7de5cf719567a317b09e88e9af43f2b8791c4d691b2db33343dfecb01544b809590
 DIST snapper-0.8.6.tar.bz2 607016 BLAKE2B 3e496fa22b1ecce2079d79caeb530ca1538febcc6bdf04aa0256e5b43bb546ea66436e60eeaae6722bc869c60579bc47c556671c5878dd671c266102516f04bb SHA512 f01a309a8dcfff455bf480ff297108e8ec3603d469d50f08740176e22bc2b8dd211de678fa8ce12c1ccd828348a35c6d347ca51b829d7b8c30b3fbaba4e9e2d9
+DIST snapper-0.8.7.tar.bz2 622381 BLAKE2B 82d1a9c91beb309e87acfa914b55b2ff5900edc023a5ecd6f2bee6b1a15adb1336656f3f1fffea4a9971aa449b7825750e6c680806d4574faada5bba0a6d14f1 SHA512 6fa63c2453f93a724f0ac23d84ff2c5aafc654463e84a4f767bb8a75a0d4fb7ca7314811179d5fefddddce0df4441298c67b473596aa720d86eeefa43011b727
diff --git a/app-backup/snapper/snapper-0.8.7.ebuild b/app-backup/snapper/snapper-0.8.7.ebuild
new file mode 100644 (file)
index 0000000..bcefeb7
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd bash-completion-r1
+
+DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
+HOMEPAGE="http://snapper.io/"
+SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lvm pam xattr"
+
+RDEPEND="dev-libs/boost:=[threads]
+       dev-libs/libxml2
+       dev-libs/icu:=
+       sys-apps/acl
+       sys-apps/dbus
+       sys-apps/util-linux
+       >=sys-fs/btrfs-progs-3.17.1
+       sys-libs/zlib
+       virtual/libintl
+       lvm? ( sys-fs/lvm2 )
+       pam? ( sys-libs/pam )
+       xattr? ( sys-apps/attr )"
+
+DEPEND="${RDEPEND}
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+PATCHES=(
+       "${FILESDIR}"/cron-confd.patch
+)
+
+src_prepare() {
+       default
+
+       sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
+               -i data/Makefile.* \
+               || die "Failed to fix systemd services and timers installation path"
+}
+
+src_configure() {
+       # ext4 code does not work anymore
+       # snapper does not build without btrfs
+       local myeconfargs=(
+               --with-conf="/etc/conf.d"
+               --disable-zypp
+               --enable-rollback
+               --disable-ext4
+               --enable-btrfs
+               $(use_enable lvm)
+               $(use_enable pam)
+               $(use_enable xattr xattrs)
+       )
+
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+       # Existing configuration file required to function
+       keepdir /etc/snapper/configs
+       newconfd data/sysconfig.snapper snapper
+       find "${D}" -name '*.la' -delete || die
+       newbashcomp "${FILESDIR}"/${PN}.bash ${PN}
+}
+
+pkg_postinst() {
+       elog "In order to use Snapper, you need to set up"
+       elog "at least one config first. To do this, run:"
+       elog "snapper create-config <subvolume>"
+       elog "For more information, see man (8) snapper or"
+       elog "http://snapper.io/documentation.html"
+}