app-vim/gundo: version bump to 2.6.2
authorTim Harder <radhermit@gentoo.org>
Sun, 28 May 2017 22:13:03 +0000 (18:13 -0400)
committerTim Harder <radhermit@gentoo.org>
Sun, 28 May 2017 22:15:24 +0000 (18:15 -0400)
And update HOMEPAGE for old version as well.

app-vim/gundo/Manifest
app-vim/gundo/gundo-2.6.1.ebuild
app-vim/gundo/gundo-2.6.2.ebuild [new file with mode: 0644]

index f3a89cab99dd51d995c632cb9bfbc7a14d3cb3f9..f31332c3969acaab1f506d174ca372ff3486f4a1 100644 (file)
@@ -1 +1,2 @@
 DIST gundo-2.6.1.tar.gz 153125 SHA256 6cacba104238169af6e9e2863cf500922a59cb6cb49885b36381a7f5d108be77 SHA512 c8b9b20ff8ef24bd94b0adc18b2cf912cbd0a07c5a70df11be39fbe69d81306027b73d9a60c9127c658c913602a819774c7b1202a8db704677da59cb9916532b WHIRLPOOL a29477209922ec6e0602f26cab96dac4c76d4f0fa4cd86df3f8f01af8d3022a57eced609423dbda73f82e01718cdd6e7bf8b2bc8c5ef2cbe465edf5401ed2152
+DIST gundo-2.6.2.tar.bz2 144107 SHA256 d03d9d96b4f65cee184438679a5d686bc0cc628b292ace02d29132af146b0982 SHA512 e03450a1bfb0a7f5013c1493f1b25b963c2bbb37fc8fa24c1b85237bd12847c3edd7b9465caae7bdadf8923dbdcdb24930b160d7824f835417bf30725fa910b4 WHIRLPOOL 3bdb7555e37374efcf684c163b937ac71f98d8c73b5f8c3f05f540dd372c937d62e94676b3b260d422277ec5d75a91aae522a88cfc88bb76d83e92309558ad19
index 1c78d498b9574aee3316b2e4ad0b3ffec196c2ae..86515acdeb8d1ad77b4dfc06f9e4e0fe68e9cf6e 100644 (file)
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python2_7 )
 inherit vim-plugin python-single-r1
 
 DESCRIPTION="vim plugin: visualize your vim undo tree"
-HOMEPAGE="https://sjl.bitbucket.org/gundo.vim/"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
 SRC_URI="https://github.com/sjl/gundo.vim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="GPL-2+"
diff --git a/app-vim/gundo/gundo-2.6.2.ebuild b/app-vim/gundo/gundo-2.6.2.ebuild
new file mode 100644 (file)
index 0000000..28f6845
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: visualize your vim undo tree"
+HOMEPAGE="https://sjl.bitbucket.io/gundo.vim/"
+SRC_URI="https://bitbucket.org/sjl/gundo.vim/get/v${PV}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+       || (
+               app-editors/vim[python,${PYTHON_USEDEP}]
+               app-editors/gvim[python,${PYTHON_USEDEP}]
+       )
+       ${PYTHON_DEPS}"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+       rm -r .gitignore .hg* package.sh README* site tests || die
+       default
+}