net-mail/swaks: Version bump to 20190914.0 and EAPI 7
authorAlarig Le Lay <alarig@swordarmor.fr>
Fri, 24 Apr 2020 08:29:25 +0000 (10:29 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 13:36:48 +0000 (16:36 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alarig Le Lay <alarig@swordarmor.fr>
Closes: https://github.com/gentoo/gentoo/pull/15496
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-mail/swaks/Manifest
net-mail/swaks/metadata.xml
net-mail/swaks/swaks-20190914.0.ebuild [new file with mode: 0644]

index 774411390ac7dedd1ce21fc05d80d6891de14903..2ccb63dceea578ff79bada62a419a0387464cc0f 100644 (file)
@@ -1 +1,2 @@
 DIST swaks-20130209.0.tar.gz 102227 BLAKE2B 4726da81869e137458f1a3776c51ae33215999bef56b1835cf8558166bd756a8186900b83c0bf32a81d1ab1cf23ec379061f4db78ae5efa51de7a6c1a69d0092 SHA512 bf3c639f2c227d8219d5bc98a3d3519886471168c16e38d036283eeb1bb786c80bb80a648637150b3eb1903ef0c0d01bc37fd7b4f55af66a20f7bef18067b118
+DIST swaks-20190914.0.tar.gz 120803 BLAKE2B 68731c22fbff5ece5c9589c3767afd6aa4fc781df8c6124a0f57d48a3dff8def31ccae1b043e78f7c066194cfe480a0edeb16e43fcd5e1b1aa75b05e65a2367e SHA512 3167435a73e7729d090cba2431d5828895c25154c36d92e0ebecd5c4e2430ca596d62bb3e6eb3b65eadabd52c8331fe3bb8a492cce3ad247fa113c0af9c67339
index 24e041dfd196c06cc1453955335031928cfc7852..e78c3a3b67ca8ecdc18937dbd56604714fd79dee 100644 (file)
@@ -1,6 +1,16 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-<!-- maintainer-needed -->
-<longdescription>"Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH" - a full-featured Perl script for testing SMTP servers.</longdescription>
+       <maintainer type="person">
+               <email>alarig@swordarmor.fr</email>
+               <name>Alarig Le Lay</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
+       <longdescription>
+               "Swiss Army Knife SMTP; Command line SMTP testing, including TLS and
+               AUTH" - a full-featured Perl script for testing SMTP servers.
+       </longdescription>
 </pkgmetadata>
diff --git a/net-mail/swaks/swaks-20190914.0.ebuild b/net-mail/swaks/swaks-20190914.0.ebuild
new file mode 100644 (file)
index 0000000..13065ec
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Swiss Army Knife SMTP; Command line SMTP testing, including TLS and AUTH"
+HOMEPAGE="https://www.jetmore.org/john/code/swaks"
+SRC_URI="https://www.jetmore.org/john/code/swaks/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="ssl"
+
+DEPEND=">=dev-lang/perl-5.8.8"
+
+RDEPEND="${DEPEND}
+               >=dev-perl/Net-DNS-0.65
+               ssl? ( >=dev-perl/Net-SSLeay-1.35 )
+               >=virtual/perl-MIME-Base64-3.07
+               >=virtual/perl-Digest-MD5-2.39
+               >=virtual/perl-Time-HiRes-1.97
+               >=virtual/perl-Time-Local-1.19
+               >=dev-perl/Authen-NTLM-1.02
+               >=dev-perl/Authen-DigestMD5-0.04
+               virtual/perl-Digest-SHA"
+
+src_compile() {
+       /usr/bin/pod2man -s 1 doc/ref.pod swaks.1 || die "man page compulation failed"
+}
+
+src_install() {
+       dobin swaks
+       doman swaks.1
+       dodoc README.txt doc/*.txt
+}