net-dialup/ppp: Bump to version 2.4.8
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 26 Feb 2020 15:31:03 +0000 (16:31 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 26 Feb 2020 15:37:06 +0000 (16:37 +0100)
with security backport for CVE-2020-8597
(0017-pppd-Fix-bounds-check-in-EAP-code.patch)

Bug: https://bugs.gentoo.org/710308
Closes: https://bugs.gentoo.org/704680
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-dialup/ppp/Manifest
net-dialup/ppp/ppp-2.4.8.ebuild [new file with mode: 0644]

index 4fd619a491a1dcb0e8f8f1231d8f907fdff32f72..193696f804784ef71d0dadc297f9f32a9fd50a91 100644 (file)
@@ -1,3 +1,5 @@
 DIST ppp-2.4.7-patches-7.tar.xz 40540 BLAKE2B 353814692aab3012f5d5ccdecc514d69357826ea7abe64a7581c562f333d868f9766f11516721cf0b116b4c1c8b01daee306d98ef7be356af6e8d16e22fc9fac SHA512 9d34c044ded09424a6d80047e88bb21130a9c2414c9ea4f52c7299d9db08b1391543b50cd97c0c8763e6943591fc325d01932b31966a1374dbfe5e977bbf4356
 DIST ppp-2.4.7.tar.gz 688117 BLAKE2B e1c94ce31d98674536929d19e956e4013eb2b02c20c34e6184c0b99b50262ad1cd7fb6f4a1ed302872527a0c164af340e15ad1e2eaf191392c3f6ae2de21f5dd SHA512 e34ce24020af6a73e7a26c83c4f73a9c83fa455b7b363794dba27bf01f70368be06bff779777843949bd77f4bc9385d6ad455ea48bf8fff4e0d73cc8fef16ae2
+DIST ppp-2.4.8-patches-02.tar.xz 39700 BLAKE2B 8e03ecf306ff415370a96ba2eca4ecdb9daed2eaa569cabbd49b94ff279dc04081cbf6749463556ba42832f4baf6f8f4cbdc0c79d6419f57080b14f3214ca992 SHA512 4f2c08a8c1d659d79c18471b41aac2d18383f86ac22231993609b548f899ee32d1ea3cc25952f00b85d1357e53bad6cf93842c49a59ecf29ed20be3020378e78
+DIST ppp-2.4.8.tar.gz 697530 BLAKE2B 235114288699db45501bc7d9ce8f36c0b5684ab0dab09da93d7f2b4f7c3eca030ae26e34dfff25efa971374fbd7fde62f121ea6aa69872658f44c5ac8c7850a2 SHA512 a99b3b6c7bd80cd133bda4e29d33c793a76f3b67e1f8db774547e88932ce29564fad390a4f51d3fe30a75e006499b95000b042ae0f64cd360548426f8091a478
 DIST ppp-dhcpc.tgz 33497 BLAKE2B ca59130012f007cf45af6bcfa468c112b0d521c8b11f42d42c566dd9de55bd6d6f1b1ceb83cbae18cfe79cb5cb36ba6c6858a4718915acc6987295008aca53da SHA512 aeaf791b14f5a09c0e2079072a157e65132cbff46e608bc0724e6a5827a01da934f5006e2774eb7105f83e607a52cb4987238f4385cf6f5cc86cbe305a556738
diff --git a/net-dialup/ppp/ppp-2.4.8.ebuild b/net-dialup/ppp/ppp-2.4.8.ebuild
new file mode 100644 (file)
index 0000000..50d429a
--- /dev/null
@@ -0,0 +1,232 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info multilib pam toolchain-funcs
+
+PATCH_VER="02"
+DESCRIPTION="Point-to-Point Protocol (PPP)"
+HOMEPAGE="https://ppp.samba.org/"
+SRC_URI="https://github.com/paulusmack/ppp/archive/ppp-2.4.8.tar.gz
+       https://dev.gentoo.org/~polynomial-c/${P}-patches-${PATCH_VER}.tar.xz
+       http://www.netservers.net.uk/gpl/ppp-dhcpc.tgz"
+
+LICENSE="BSD GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+IUSE="activefilter atm dhcp eap-tls gtk ipv6 libressl pam radius"
+
+DEPEND="
+       activefilter? ( net-libs/libpcap )
+       atm? ( net-dialup/linux-atm )
+       pam? ( sys-libs/pam )
+       gtk? ( x11-libs/gtk+:2 )
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:= )
+"
+RDEPEND="${DEPEND}
+       !<net-misc/netifrc-0.7.1"
+PDEPEND="net-dialup/ppp-scripts"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+       mv "${WORKDIR}/dhcp" "${S}/pppd/plugins" || die
+
+       if ! use eap-tls ; then
+               rm "${WORKDIR}"/patches/8?_all_eaptls-* || die
+       fi
+       eapply "${WORKDIR}"/patches
+
+       if use atm ; then
+               einfo "Enabling PPPoATM support"
+               sed -i '/^#HAVE_LIBATM=yes/s:#::' \
+                       pppd/plugins/pppoatm/Makefile.linux || die
+       fi
+
+       if ! use activefilter ; then
+               einfo "Disabling active filter"
+               sed -i '/^FILTER=y/s:^:#:' pppd/Makefile.linux || die
+       fi
+
+       if use pam ; then
+               einfo "Enabling PAM"
+               sed -i '/^#USE_PAM=y/s:^#::' pppd/Makefile.linux || die
+       fi
+
+       if use ipv6 ; then
+               einfo "Enabling IPv6"
+               sed -i '/#HAVE_INET6/s:#::' pppd/Makefile.linux || die
+               echo "+ipv6" >> etc.ppp/options || die
+       fi
+
+       einfo "Enabling CBCP"
+       sed -i '/^#CBCP=y/s:#::' pppd/Makefile.linux || die
+
+       if use dhcp ; then
+               einfo "Adding ppp-dhcp plugin files"
+               sed \
+                       -e '/^SUBDIRS :=/s:$: dhcp:' \
+                       -i pppd/plugins/Makefile.linux || die
+       fi
+
+       # Set correct libdir
+       sed -i -e "s:/lib/pppd:/$(get_libdir)/pppd:" \
+               pppd/{pathnames.h,pppd.8} || die
+
+       if use radius ; then
+               #set the right paths in radiusclient.conf
+               sed -e "s:/usr/local/etc:/etc:" \
+                       -e "s:/usr/local/sbin:/usr/sbin:" \
+                       -i pppd/plugins/radius/etc/radiusclient.conf || die
+               #set config dir to /etc/ppp/radius
+               sed -i -e "s:/etc/radiusclient:/etc/ppp/radius:g" \
+                       pppd/plugins/radius/{*.8,*.c,*.h} \
+                       pppd/plugins/radius/etc/* || die
+       else
+               einfo "Disabling radius"
+               sed -i -e '/+= radius/s:^:#:' pppd/plugins/Makefile.linux || die
+       fi
+
+       # Respect our pkg-config settings.
+       sed -i \
+               -e 's:pkg-config:$(PKG_CONFIG):' \
+               contrib/pppgetpass/Makefile.linux || die
+       sed -i \
+               -e '/^LIBS/{s:-L/usr/local/ssl/lib::;s:-lcrypto:`$(PKG_CONFIG) --libs libcrypto`:}' \
+               pppd/Makefile.linux || die
+
+       eapply_user #549588
+}
+
+src_compile() {
+       tc-export AR CC PKG_CONFIG
+       emake COPTS="${CFLAGS} -D_GNU_SOURCE"
+
+       # build pppgetpass
+       cd contrib/pppgetpass || die
+       if use gtk ; then
+               emake -f Makefile.linux
+       else
+               emake pppgetpass.vt
+       fi
+}
+
+src_install() {
+       local i
+       for i in chat pppd pppdump pppstats ; do
+               doman ${i}/${i}.8
+               dosbin ${i}/${i}
+       done
+       fperms u+s-w /usr/sbin/pppd
+
+       # Install pppd header files
+       emake -C pppd INSTROOT="${D}" install-devel
+
+       dosbin pppd/plugins/rp-pppoe/pppoe-discovery
+
+       dodir /etc/ppp/peers
+       insinto /etc/ppp
+       insopts -m0600
+       newins etc.ppp/pap-secrets pap-secrets.example
+       newins etc.ppp/chap-secrets chap-secrets.example
+
+       insopts -m0644
+       doins etc.ppp/options
+
+       pamd_mimic_system ppp auth account session
+
+       local PLUGINS_DIR="/usr/$(get_libdir)/pppd/${PV}"
+       insinto "${PLUGINS_DIR}"
+       insopts -m0755
+       doins pppd/plugins/minconn.so
+       doins pppd/plugins/passprompt.so
+       doins pppd/plugins/passwordfd.so
+       doins pppd/plugins/winbind.so
+       doins pppd/plugins/rp-pppoe/rp-pppoe.so
+       doins pppd/plugins/pppol2tp/openl2tp.so
+       doins pppd/plugins/pppol2tp/pppol2tp.so
+       if use atm ; then
+               doins pppd/plugins/pppoatm/pppoatm.so
+       fi
+       if use dhcp ; then
+               doins pppd/plugins/dhcp/dhcpc.so
+       fi
+       if use radius ; then
+               doins pppd/plugins/radius/rad{ius,attr,realms}.so
+
+               #Copy radiusclient configuration files (#92878)
+               insinto /etc/ppp/radius
+               insopts -m0644
+               doins pppd/plugins/radius/etc/{dictionary*,issue,port-id-map,radiusclient.conf,realms,servers}
+
+               doman pppd/plugins/radius/pppd-rad{ius,attr}.8
+       fi
+
+       insinto /etc/modprobe.d
+       insopts -m0644
+       newins "${FILESDIR}/modules.ppp" ppp.conf
+
+       dodoc PLUGINS README* SETUP Changes-2.3 FAQ
+       dodoc "${FILESDIR}/README.mpls"
+
+       dosbin scripts/p{on,off,log}
+       doman scripts/pon.1
+
+       # Adding misc. specialized scripts to doc dir
+       insinto /usr/share/doc/${PF}/scripts/chatchat
+       doins scripts/chatchat/*
+       insinto /usr/share/doc/${PF}/scripts
+       doins scripts/*
+
+       if use gtk ; then
+               dosbin contrib/pppgetpass/{pppgetpass.vt,pppgetpass.gtk}
+               newsbin contrib/pppgetpass/pppgetpass.sh pppgetpass
+       else
+               newsbin contrib/pppgetpass/pppgetpass.vt pppgetpass
+       fi
+       doman contrib/pppgetpass/pppgetpass.8
+}
+
+pkg_postinst() {
+       if linux-info_get_any_version && linux_config_src_exists ; then
+               echo
+               ewarn "If the following test report contains a missing kernel configuration option that you need,"
+               ewarn "you should reconfigure and rebuild your kernel before running pppd."
+               CONFIG_CHECK="~PPP ~PPP_ASYNC ~PPP_SYNC_TTY"
+               local ERROR_PPP="CONFIG_PPP:\t missing PPP support (REQUIRED)"
+               local ERROR_PPP_ASYNC="CONFIG_PPP_ASYNC:\t missing asynchronous serial line discipline (optional, but highly recommended)"
+               local WARNING_PPP_SYNC_TTY="CONFIG_PPP_SYNC_TTY:\t missing synchronous serial line discipline (optional; used by 'sync' pppd option)"
+               if use activefilter ; then
+                       CONFIG_CHECK="${CONFIG_CHECK} ~PPP_FILTER"
+                       local ERROR_PPP_FILTER="CONFIG_PPP_FILTER:\t missing PPP filtering support (REQUIRED)"
+               fi
+               CONFIG_CHECK="${CONFIG_CHECK} ~PPP_DEFLATE ~PPP_BSDCOMP ~PPP_MPPE"
+               local ERROR_PPP_DEFLATE="CONFIG_PPP_DEFLATE:\t missing Deflate compression (optional, but highly recommended)"
+               local ERROR_PPP_BSDCOMP="CONFIG_PPP_BSDCOMP:\t missing BSD-Compress compression (optional, but highly recommended)"
+               local WARNING_PPP_MPPE="CONFIG_PPP_MPPE:\t missing MPPE encryption (optional, mostly used by PPTP links)"
+               CONFIG_CHECK="${CONFIG_CHECK} ~PPPOE ~PACKET"
+               local WARNING_PPPOE="CONFIG_PPPOE:\t missing PPPoE support (optional, needed by rp-pppoe plugin)"
+               local WARNING_PACKET="CONFIG_PACKET:\t missing AF_PACKET support (optional, used by rp-pppoe and dhcpc plugins)"
+               if use atm ; then
+                       CONFIG_CHECK="${CONFIG_CHECK} ~PPPOATM"
+                       local WARNING_PPPOATM="CONFIG_PPPOATM:\t missing PPPoA support (optional, needed by pppoatm plugin)"
+               fi
+               check_extra_config
+       fi
+
+       # create *-secrets files if not exists
+       [[ -f "${EROOT}/etc/ppp/pap-secrets" ]] || \
+               cp -pP "${EROOT}/etc/ppp/pap-secrets.example" "${EROOT}/etc/ppp/pap-secrets"
+       [[ -f "${EROOT}/etc/ppp/chap-secrets" ]] || \
+               cp -pP "${EROOT}/etc/ppp/chap-secrets.example" "${EROOT}/etc/ppp/chap-secrets"
+
+       # lib name has changed
+       sed -i -e "s:^pppoe.so:rp-pppoe.so:" "${EROOT}/etc/ppp/options" || die
+
+       echo
+       elog "Pon, poff and plog scripts have been supplied for experienced users."
+       elog "Users needing particular scripts (ssh,rsh,etc.) should check out the"
+       elog "/usr/share/doc/${PF}/scripts directory."
+}