net-im/zoom: Version bump to 3.5.374815.0324.
authorUlrich Müller <ulm@gentoo.org>
Thu, 26 Mar 2020 11:30:10 +0000 (12:30 +0100)
committerUlrich Müller <ulm@gentoo.org>
Thu, 26 Mar 2020 11:34:51 +0000 (12:34 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.21
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
net-im/zoom/Manifest
net-im/zoom/zoom-3.5.374815.0324.ebuild [new file with mode: 0644]

index 1f86e1ac7be23ed4ec5b554b9a486466b7c9c507..c29a623f279beb0f2533d31e00283e6ffc02b701 100644 (file)
@@ -1,2 +1,4 @@
 DIST zoom-3.5.372466.0322_i686.tar.xz 48479676 BLAKE2B b6fdc176690ce6e4b107ebdd0f348dcbf578c815067c6616eca72e2bc98b993033074525326da74a1377ab61b4db366e816c6213291f59a29dfb0f8f3336fcbc SHA512 ac3e30baa9d251ac2ecde9bc33857d15857c52c28a6632ca7173710e3fff3424f33d55d03754a3d703b6de3578e6cc2b973b2f0eccf8b852b3edb7f2017ac4cb
 DIST zoom-3.5.372466.0322_x86_64.tar.xz 72594544 BLAKE2B dac548df8cfbcdbd90427b1a0c85c6be8798b6065b420e25dc279c8d104e6fc0f9201ad77e5451bf350f11fc26745c5c9e238675ce78e5c54216573c6af829bc SHA512 87058be065e51ea3e85801b4a40e4141278e33719d1390567bbb83010ebd90cf7c48262433227585709c3376278ff7b09d77628920672013c4df3ad97ea0d2c6
+DIST zoom-3.5.374815.0324_i686.tar.xz 48481420 BLAKE2B 5c40be4c5cf1e72766f35ea971384c514a49f8ed882af6791b7681c84082830ee120147fcd138b382509b4ebf5dc84a479f2ad40e7eed0dd332a02d4bc141d8c SHA512 354e7e8af733dad1483e138621574f675822fe9f5739092a11495f6f584917413012866d171e076b7156c6097e71c85f8e53dba1fd9db2de59af55256ab8479e
+DIST zoom-3.5.374815.0324_x86_64.tar.xz 72609300 BLAKE2B 2f51eecd88cc636f03778c68101b2c5919982025232da5cd6a378a2e681ad76d39d9db201ff14d5601498495909dfb934ebf21752cd7658ada6edc28379bed90 SHA512 632002b6942f15e1f22ba147de9a9463253c2b374e4382b4c2ce21e5685ad4fd688929141095d09e2fa0ed2adb5b0dc6ba9aba2e4fa54ae69fea24b95bf474c4
diff --git a/net-im/zoom/zoom-3.5.374815.0324.ebuild b/net-im/zoom/zoom-3.5.374815.0324.ebuild
new file mode 100644 (file)
index 0000000..c947529
--- /dev/null
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+DESCRIPTION="Video conferencing and web conferencing service"
+HOMEPAGE="https://zoom.us/"
+SRC_URI="amd64? ( https://zoom.us/client/${PV}/${PN}_x86_64.tar.xz -> ${P}_x86_64.tar.xz )
+       x86? ( https://zoom.us/client/${PV}/${PN}_i686.tar.xz -> ${P}_i686.tar.xz )"
+S="${WORKDIR}/${PN}"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="mirror bindist strip"
+
+RDEPEND="dev-libs/glib:2
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtdeclarative:5
+       dev-qt/qtgraphicaleffects:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtpositioning:5
+       dev-qt/qtprintsupport:5
+       dev-qt/qtquickcontrols:5
+       dev-qt/qtscript:5
+       dev-qt/qtwebchannel:5
+       dev-qt/qtwebengine:5
+       dev-qt/qtwidgets:5
+       media-libs/libglvnd
+       sys-apps/dbus
+       sys-apps/util-linux
+       x11-libs/libX11
+       x11-libs/libxcb
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXtst
+       x11-libs/xcb-util-image
+       x11-libs/xcb-util-keysyms"
+
+QA_PREBUILT="opt/zoom/*"
+
+src_install() {
+       insinto /opt/zoom
+       exeinto /opt/zoom
+       doins -r json sip timezones translations
+       doins *.pcm *.pem *.sh Embedded.properties version.txt
+       use amd64 && doins icudtl.dat
+       doexe zoom{,.sh,linux} zopen ZoomLauncher
+       make_wrapper zoom ./zoom /opt/zoom
+       make_desktop_entry "zoom %U" Zoom audio-headset "" \
+               "MimeType=x-scheme-handler/zoommtg;application/x-zoom;"
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+}