sys-apps/moreutils: Respect compiler environment
authorSam James (sam_c) <sam@cmpct.info>
Fri, 8 May 2020 03:01:45 +0000 (03:01 +0000)
committerThomas Deutschmann <whissi@gentoo.org>
Sat, 9 May 2020 13:48:22 +0000 (15:48 +0200)
Now respects CC as well as CFLAGS.

This patch is taken from upstream, not yet in
a release.

Thanks-to: Agostino Sarubbo <ago@gentoo.org>
Closes: https://bugs.gentoo.org/721394
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15703
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/moreutils/files/moreutils-0.63-respect-env.patch [new file with mode: 0644]
sys-apps/moreutils/moreutils-0.63.ebuild

diff --git a/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch b/sys-apps/moreutils/files/moreutils-0.63-respect-env.patch
new file mode 100644 (file)
index 0000000..a4091cf
--- /dev/null
@@ -0,0 +1,38 @@
+From 6c88aaa6b828d7bd7c1dccb3b842594d48c1764c Mon Sep 17 00:00:00 2001
+From: Nicolas Schier <nicolas@fjasle.eu>
+Date: Wed, 27 Nov 2019 21:16:12 +0100
+Subject: is_utf8: allow propagation of compiler and linker flags
+
+Allow propagating compiler and linker flags via overrides of CFLAGS and
+LDFLAGS variables.  This allows enabling of hardening flags w/o
+modification of the original Makefile.
+
+Signed-off-by: Nicolas Schier <nicolas@fjasle.eu>
+---
+ is_utf8/Makefile | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/is_utf8/Makefile b/is_utf8/Makefile
+index 4ebf8be..13b1021 100644
+--- a/is_utf8/Makefile
++++ b/is_utf8/Makefile
+@@ -38,13 +38,13 @@ SONAME = $(LINKERNAME).$(VERSION)
+ REALNAME = $(SONAME).$(MINOR).$(RELEASE)
+ CC = gcc
+-CFLAGS = -O3 -Wextra -Wall -ansi -Wstrict-prototypes
++CFLAGS ?= -O3 -Wextra -Wall -ansi -Wstrict-prototypes
+ $(NAME): $(OBJ)
+-      $(CC) $(CFLAGS) -o $(NAME) $(OBJ)
++      $(CC) $(CFLAGS) -o $(NAME) $(OBJ) $(LDFLAGS)
+ IS_UTF8_LIB:
+-      $(CC) --shared -fPIC $(CFLAGS) $(LIB_SRC) -o $(LINKERNAME)
++      $(CC) --shared -fPIC $(CFLAGS) $(LDFLAGS) $(LIB_SRC) -o $(LINKERNAME)
+ all:
+               @make $(NAME)
+-- 
+cgit v1.2.3
+
index cda09be7454ffd34dc4ddc267256b14519df84d4..3717d9f1f27b8ad68162cf56579baf19127edb7c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -28,6 +28,10 @@ DEPEND="
                app-text/docbook-xml-dtd:4.4
        )"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-respect-env.patch
+)
+
 src_prepare() {
        # don't build manpages
        if ! use doc ; then