dev-libs/libpeas: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sat, 25 Jun 2016 09:46:06 +0000 (11:46 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 25 Jun 2016 12:19:57 +0000 (14:19 +0200)
Package-Manager: portage-2.3.0_rc1

dev-libs/libpeas/Manifest
dev-libs/libpeas/libpeas-1.14.0-r1.ebuild [deleted file]

index 7b8742c67abc186a2e063efbe2e21662234372e4..6cc67f15b60ef5b81136a795b9688b2fe260c569 100644 (file)
@@ -1,2 +1 @@
-DIST libpeas-1.14.0.tar.xz 546092 SHA256 5e4b3a8968b71497ab26a7a528c414c4c640c5724328fa3507854f04788e2d76 SHA512 64559d317833c53d8c64cb627ccc2efff8df1469192bf71504aee8558c76562e987d9c7618c192e621422710d524b91a6496a1255a441242067fc71c9283bddf WHIRLPOOL dd2072446fbf2b36443e60745b53aab8d4eac8cb6c624108b722faa27eea29422f99d0cb0253f626a051d0754778ee48d9596e539f2e97916ddfa75ed7435cc2
 DIST libpeas-1.16.0.tar.xz 548972 SHA256 b093008ecd65f7d55c80517589509698ff15ad41f664b11a3eb88ff461b1454e SHA512 ae3024c8229222f8d683dd88d6f2aeb61e17b676e317e6d824b72e1fecce577f138625933afd7ad6627de961d2b95dcdd5a3593256f2acd05a15e0eede389c6e WHIRLPOOL 367f24916b3289e8e97c16e9367f94533a879945f72a1214d8a67fab070d30a33137768f0be173bd9151f6ea794297225231eade015c476da1ea88b09bc14d32
diff --git a/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild b/dev-libs/libpeas/libpeas-1.14.0-r1.ebuild
deleted file mode 100644 (file)
index 62bc1ca..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-
-inherit autotools eutils gnome2 multilib python-r1 virtualx
-
-DESCRIPTION="A GObject plugins library"
-HOMEPAGE="https://developer.gnome.org/libpeas/stable/"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
-IUSE="+gtk glade jit lua +python"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ?? ( $(python_gen_useflags 'python3*') ) )"
-
-RDEPEND="
-       >=dev-libs/glib-2.38:2
-       >=dev-libs/gobject-introspection-1.39
-       glade? ( >=dev-util/glade-3.9.1:3.10 )
-       gtk? ( >=x11-libs/gtk+-3:3[introspection] )
-       lua? (
-               >=dev-lua/lgi-0.9.0
-               jit? ( >=dev-lang/luajit-2:2 )
-               !jit? ( =dev-lang/lua-5.1*:0 ) )
-       python? (
-               ${PYTHON_DEPS}
-               >=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
-       >=dev-util/gtk-doc-am-1.11
-       >=dev-util/intltool-0.40
-       virtual/pkgconfig
-
-       dev-libs/gobject-introspection-common
-       gnome-base/gnome-common
-"
-# eautoreconf needs gobject-introspection-common, gnome-common
-
-src_prepare() {
-       # Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
-       epatch "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
-       eautoreconf
-       gnome2_src_prepare
-}
-
-src_configure() {
-       # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
-       # What do we do about gdb, valgrind, gcov, etc?
-       local myconf=(
-               $(use_enable glade glade-catalog)
-               $(use_enable gtk)
-               --disable-static
-
-               # possibly overriden below
-               --disable-python{2,3}
-               --disable-lua5.1
-               --disable-luajit
-       )
-
-       if use lua ; then
-               if use jit ; then
-                       myconf+=( --enable-lua5.1 --enable-luajit )
-               else
-                       myconf+=( --enable-lua5.1 )
-               fi
-       fi
-
-       python_configure() {
-               local v
-               python_is_python3 && v=3 || v=2
-               myconf+=(
-                       "--enable-python${v}"
-                       # it is just 'PYTHON' for py3 in the build system
-                       "PYTHON${v#3}=${PYTHON}"
-                       "PYTHON${v}_CONFIG=$(python_get_PYTHON_CONFIG)"
-               )
-       }
-       use python && python_foreach_impl python_configure
-
-       gnome2_src_configure "${myconf[@]}"
-}
-
-src_test() {
-       # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
-       # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
-       # To reproduce:
-       # >>> from gi.repository import Gtk
-       # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
-       # This should return True, it returns False for Xvfb
-       Xemake check
-}