games-action/supertuxkart: remove 0.9.1
authorMichael Palimaka <kensington@gentoo.org>
Sat, 30 Sep 2017 05:23:34 +0000 (15:23 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 30 Sep 2017 05:32:12 +0000 (15:32 +1000)
Package-Manager: Portage-2.3.8, Repoman-2.3.3

games-action/supertuxkart/Manifest
games-action/supertuxkart/supertuxkart-0.9.1.ebuild [deleted file]

index 93f2de11f33436b86615fc65ff8d61f40503e03f..2fafd85e8eb2aab26bded7f9280d118eaec26325 100644 (file)
@@ -1,3 +1,2 @@
-DIST supertuxkart-0.9.1-src.tar.xz 425822808 SHA256 c50f00a71df165fb613d20e86bea2d9d5e51ed3e27e1d436fbac3b07cf2ea149 SHA512 11ea064210ea6bc36258f08e57c6aac46739133017ad3ba97ca0edd84c818c2f72dae60bbe7cd79135be9785fb0e15c9904b151c894e1c21b881598113344cf4 WHIRLPOOL 8acd59e878b44f8e504d57687ea1bbece05d5f14b29e0c62a22183729129fb115fccb9a1a89d5e0a86881ac6487c36ea520aab835ba5efaaa3c71471fda9b15f
 DIST supertuxkart-0.9.2-src.tar.xz 501606188 SHA256 0b080bb098a26adb552d6fd48905bcb6b1e873ef1567457d7268d7d3aaa48282 SHA512 57f11d518736f88044d1cb73e1dfcc92f5667f3b1147ab7e54435f6bc560fe856c3650410410da5fa048bf23d0b64fc8a9887c830001e1435b0359c9163e71b0 WHIRLPOOL c534854127981821412437632fdf9ff239988199d60f8d582b59bd624dff87f5e37a5cb54020b679e9fb6d440187a5bd0e0c2eb00311e2ae8de6ba58fb1d1d82
 DIST supertuxkart.png 4435 SHA256 99bc1801cb0514946cb0171d6d5a84484b6dc881edfa7f096b6eb5fea2f28828 SHA512 a180332f79220431922fa8b351cb476ebc5d9d1df09f20707eb3bdd7002fd264cb027b8190c73c5221050e6e8601beb6758a5809d05aedfb18f0bdb426f47eda WHIRLPOOL eef651802a927b451226fc06a682d7dea68b65b05195130ccfc7544165f26f65bda4fc9565e09d6487d02be3cf57880b0c6c257f26587c6bc6d30afc6aa5d3c2
diff --git a/games-action/supertuxkart/supertuxkart-0.9.1.ebuild b/games-action/supertuxkart/supertuxkart-0.9.1.ebuild
deleted file mode 100644 (file)
index 76bf131..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit gnome2-utils cmake-utils eutils games
-
-DESCRIPTION="A kart racing game starring Tux, the linux penguin (TuxKart fork)"
-HOMEPAGE="https://supertuxkart.net/"
-SRC_URI="mirror://sourceforge/supertuxkart/SuperTuxKart/${PV}/${P}-src.tar.xz
-       mirror://gentoo/${PN}.png"
-
-LICENSE="GPL-3 CC-BY-SA-3.0 CC-BY-2.0 public-domain ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug fribidi wiimote"
-
-# don't unbundle irrlicht and bullet
-# both are modified and system versions will break the game
-# https://sourceforge.net/p/irrlicht/feature-requests/138/
-
-RDEPEND="media-libs/libpng:0
-       media-libs/libvorbis
-       media-libs/openal
-       net-misc/curl
-       sys-libs/zlib
-       virtual/glu
-       virtual/jpeg:0
-       virtual/libintl
-       virtual/opengl
-       x11-libs/libX11
-       x11-libs/libXxf86vm
-       fribidi? ( dev-libs/fribidi )
-       wiimote? ( net-wireless/bluez )"
-DEPEND="${RDEPEND}
-       sys-devel/gettext
-       virtual/pkgconfig"
-
-src_prepare() {
-       # inconsistent handling of debug definition
-       # avoid using Debug build type
-       if use debug ; then
-               sed -i \
-                       -e 's/add_definitions(-DNDEBUG)/add_definitions(-DDEBUG)/' \
-                       CMakeLists.txt || die
-       fi
-}
-
-src_configure() {
-       local mycmakeargs=(
-               $(cmake-utils_use_use fribidi FRIBIDI)
-               $(cmake-utils_use_use wiimote WIIUSE)
-               -DSTK_INSTALL_BINARY_DIR="${GAMES_BINDIR}"
-               -DSTK_INSTALL_DATA_DIR="${GAMES_DATADIR}"/${PN}
-       )
-
-       cmake-utils_src_configure
-}
-
-src_compile() {
-       cmake-utils_src_compile
-}
-
-src_install() {
-       DOCS="AUTHORS CHANGELOG.md README.md TODO.md" \
-               cmake-utils_src_install
-       doicon -s 64 "${DISTDIR}"/${PN}.png
-       prepgamesdirs
-}
-
-pkg_preinst() {
-       games_pkg_preinst
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       games_pkg_postinst
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-}