games-roguelike/stone-soup: Bump to 0.21.1
authorErik Mackdanz <stasibear@gentoo.org>
Fri, 3 Aug 2018 00:01:56 +0000 (19:01 -0500)
committerErik Mackdanz <stasibear@gentoo.org>
Fri, 3 Aug 2018 00:01:56 +0000 (19:01 -0500)
Closes: https://bugs.gentoo.org/659200
Package-Manager: Portage-2.3.43, Repoman-2.3.10

games-roguelike/stone-soup/Manifest
games-roguelike/stone-soup/stone-soup-0.21.1.ebuild [new file with mode: 0644]

index 2df6df8fb5b00235241bfd41e2233522da71598a..2f7f184949eb9bed3f0b7f4231f53e6c78f1788c 100644 (file)
@@ -1,3 +1,4 @@
 DIST stone-soup.png 1351 BLAKE2B cc31abd59701aa6f0fb0bdcd90630ceebf7b3cb8b60f0e2817f8800c5bc4b3a5b9fef63c90a97b6248f306e7e3da0df3863a2195b8771863344d2443e7956d59 SHA512 4695204c8b936f7aac1ba15b02a6115a955fb2c56aa9a0b968ff007bc9a1a59b608110d60cce5625a9b92cd2c869bbea7e15433a53c1a338622809477a5846bc
 DIST stone-soup.svg 68546 BLAKE2B 7c66286c9e8a3516e8483b3edb628a59fce29d8d248c3fd5b06e308782bbc651814f21ec958b30c36074a2576ced4bb10f291b5236da6f6e865ce1d7cefdf96d SHA512 dca555271faf704eb8ecdf5ee8a763df42cdeba94e9c163608c438cfc73c6fbf53416547050cad57f477ade191842e701785b65b7a9f18e27ceab05df8f2f75f
 DIST stone_soup-0.20.1.tar.xz 28372712 BLAKE2B c12a76afcaf1691a74f23bc2b2927ac2573cb83c602a50aab1567b9e2077c6f12f0847c8c27f17c45941660ab0fac1c28b2531c176c1fc0d4e946b84456d4e75 SHA512 420ccc3c66977da8ae15f9c0465b01a6260ad5db450efced3041455674922e714d9aaed226e1bc32fa3c22bca1ec06bd91979a9378c6ab08fbe1d2bfc3f0da4a
+DIST stone_soup-0.21.1.tar.xz 29091300 BLAKE2B 0ce29554483eb244eb74ef08c3e2a7d253037cec141e90fba0bf5f59eebb30dad0668c997eba0d6ea12a354d515fe770cc7fcf6a2afb8c968a09cb9a337bcde4 SHA512 1fa50e5b434391b6f3abad62931318f28dd2af3d3148a72c1f2ff80142f3ce9128b8fe6e5b8fbcc502a3d7e79b777bd9f345f8cca06d7e3dbe7575a42f8bd9e7
diff --git a/games-roguelike/stone-soup/stone-soup-0.21.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.21.1.ebuild
new file mode 100644 (file)
index 0000000..14ea7d7
--- /dev/null
@@ -0,0 +1,143 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+## TODO
+# add sound support (no sound files)
+
+EAPI=6
+VIRTUALX_REQUIRED="manual"
+inherit eutils gnome2-utils toolchain-funcs eapi7-ver
+
+MY_P="stone_soup-${PV}"
+DESCRIPTION="Role-playing roguelike game of exploration and treasure-hunting in dungeons"
+HOMEPAGE="http://crawl.develz.org/wordpress/"
+SRC_URI="
+       https://crawl.develz.org/release/$(ver_cut 1-2)/${PN/-/_}-${PV}.tar.xz
+       https://dev.gentoo.org/~hasufell/distfiles/${PN}.png
+       https://dev.gentoo.org/~hasufell/distfiles/${PN}.svg
+"
+
+# 3-clause BSD: mt19937ar.cc, MSVC/stdint.h
+# 2-clause BSD: all contributions by Steve Noonan and Jesse Luehrs
+# Public Domain|CC0: most of tiles
+# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
+LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug luajit ncurses test +tiles"
+# test is broken
+# see https://crawl.develz.org/mantis/view.php?id=6121
+RESTRICT="test"
+
+RDEPEND="
+       dev-db/sqlite:3
+       luajit? ( >=dev-lang/luajit-2.0.0 )
+       sys-libs/zlib
+       !ncurses? ( !tiles? ( sys-libs/ncurses:0 ) )
+       ncurses? ( sys-libs/ncurses:0 )
+       tiles? (
+               media-fonts/dejavu
+               media-libs/freetype:2
+               media-libs/libpng:0
+               media-libs/libsdl2[X,opengl,video]
+               media-libs/sdl2-image[png]
+               virtual/glu
+               virtual/opengl
+       )"
+DEPEND="${RDEPEND}
+       dev-lang/perl
+       sys-devel/flex
+       virtual/pkgconfig
+       virtual/yacc
+       tiles? (
+               sys-libs/ncurses:0
+       )"
+
+S=${WORKDIR}/${MY_P}/source
+S_TEST=${WORKDIR}/${MY_P}_test/source
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.20.1-rltiles-ldflags-libs.patch
+)
+
+pkg_setup() {
+       if use !ncurses && use !tiles ; then
+               ewarn "Neither ncurses nor tiles frontend"
+               ewarn "selected, choosing ncurses only."
+               ewarn "Note that you can also enable both."
+       fi
+}
+
+src_prepare() {
+       default
+
+       rm -r contrib/{fonts,freetype,libpng,pcre,sdl2,sdl2-image,sdl2-mixer,sqlite,zlib} || die
+}
+
+src_compile() {
+       export HOSTCXX=$(tc-getBUILD_CXX)
+
+       # leave DATADIR at the top
+       myemakeargs=(
+               $(usex debug "FULLDEBUG=y DEBUG=y" "")
+               $(usex luajit "" "BUILD_LUA=yes") # luajit is not bundled
+               AR="$(tc-getAR)"
+               CFOPTIMIZE=''
+               CFOTHERS="${CXXFLAGS}"
+               DATADIR="/usr/share/${PN}"
+               GCC="$(tc-getCC)"
+               GXX="$(tc-getCXX)"
+               LDFLAGS="${LDFLAGS}"
+               MAKEOPTS="${MAKEOPTS}"
+               PKGCONFIG="$(tc-getPKG_CONFIG)"
+               RANLIB="$(tc-getRANLIB)"
+               SAVEDIR="~/.crawl"
+               STRIP=touch
+               USE_LUAJIT=$(usex luajit "yes" "")
+               V=1
+               prefix="/usr"
+       )
+
+       if use ncurses || (use !ncurses && use !tiles) ; then
+               emake "${myemakeargs[@]}"
+               # move it in case we build both variants
+               use tiles && { mv crawl "${WORKDIR}"/crawl-ncurses || die ;}
+       fi
+
+       if use tiles ; then
+               emake clean
+               emake "${myemakeargs[@]}" "TILES=y"
+       fi
+}
+
+src_install() {
+       emake "${myemakeargs[@]}" $(usex tiles "TILES=y" "") DESTDIR="${D}" prefix_fp="" bin_prefix="${D}/usr/bin" install
+       [[ -e "${WORKDIR}"/crawl-ncurses ]] && dobin "${WORKDIR}"/crawl-ncurses
+
+       # don't relocate docs, needed at runtime
+       rm -rf "${D}/usr/share/${PN}"/docs/license
+
+       # icons and menu for graphical build
+       if use tiles ; then
+               doicon -s 48 "${DISTDIR}"/${PN}.png
+               doicon -s scalable "${DISTDIR}"/${PN}.svg
+               make_desktop_entry crawl
+       fi
+}
+
+pkg_preinst() {
+       gnome2_icon_savelist
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+
+       if use tiles && use ncurses ; then
+               elog "Since you have enabled both tiles and ncurses frontends"
+               elog "the ncurses binary is called 'crawl-ncurses' and the"
+               elog "tiles binary is called 'crawl'."
+       fi
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}