games-strategy/spaz: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Sun, 30 Jun 2019 08:22:19 +0000 (10:22 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sun, 30 Jun 2019 08:22:19 +0000 (10:22 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
games-strategy/spaz/spaz-1.605-r1.ebuild [moved from games-strategy/spaz/spaz-1.605.ebuild with 61% similarity]

similarity index 61%
rename from games-strategy/spaz/spaz-1.605.ebuild
rename to games-strategy/spaz/spaz-1.605-r1.ebuild
index 943dbedf37799de3c912e9fc35e64d56d2310e15..98f1843747b1d4f3bced3e82ef5531b2b078501b 100644 (file)
@@ -1,12 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
-
-inherit unpacker games
+EAPI=7
+inherit desktop eutils unpacker
 
 DESCRIPTION="Space Pirates and Zombies"
-HOMEPAGE="http://spacepiratesandzombies.com"
+HOMEPAGE="http://minmax-games.com/SpacePiratesAndZombies/"
 SRC_URI="${PN}-linux-humblebundle-09182012-bin"
 LICENSE="LOKI-EULA"
 SLOT="0"
@@ -14,9 +13,12 @@ KEYWORDS="-* ~amd64 ~x86"
 IUSE="alsa pulseaudio"
 RESTRICT="bindist fetch strip"
 
-DEPEND="app-arch/unzip"
-RDEPEND=">=media-libs/openal-1.15.1[alsa?,pulseaudio?,abi_x86_32(-)]
-       >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]"
+DEPEND=""
+BDEPEND="app-arch/unzip"
+RDEPEND="
+       >=media-libs/openal-1.15.1[alsa?,pulseaudio?,abi_x86_32(-)]
+       >=media-libs/libsdl-1.2.15-r4[abi_x86_32(-)]
+"
 
 S="${WORKDIR}"/data
 
@@ -27,7 +29,7 @@ src_unpack() {
 }
 
 src_install() {
-       local dir="${GAMES_PREFIX_OPT}/${PN}"
+       local dir="/opt/${PN}"
 
        insinto "${dir}"
        exeinto "${dir}"
@@ -37,8 +39,6 @@ src_install() {
        newicon SPAZ.png spaz.png
        dodoc README-linux.txt
 
-       games_make_wrapper ${PN} ./SPAZ "${dir}" "${dir}"
+       make_wrapper ${PN} ./SPAZ "${dir}" "${dir}"
        make_desktop_entry ${PN} "Space Pirates and Zombies" ${PN}
-
-       prepgamesdirs
 }