media-video/guvcview: EAPI-7 bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Thu, 21 May 2020 19:36:33 +0000 (21:36 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Thu, 21 May 2020 19:36:44 +0000 (21:36 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-video/guvcview/guvcview-2.0.6-r1.ebuild

index 76ae9ce37c01744dd69f6e9acd2865cd5eb62074..a24e2f2d3041d6eca38af169f2ce89dc8e307037 100644 (file)
@@ -1,11 +1,10 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-
-inherit autotools flag-o-matic qmake-utils toolchain-funcs
+EAPI=7
 
 MY_P=${PN}-src-${PV}
+inherit autotools flag-o-matic qmake-utils toolchain-funcs
 
 DESCRIPTION="Simple Qt5 or GTK+3 interface for capturing and viewing video from v4l2 devices"
 HOMEPAGE="http://guvcview.sourceforge.net/"
@@ -16,17 +15,22 @@ SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE="gsl pulseaudio qt5"
 
+BDEPEND="
+       dev-util/intltool
+       sys-devel/autoconf-archive
+       sys-devel/gettext
+       virtual/pkgconfig
+"
 RDEPEND="
        >=dev-libs/glib-2.10
        media-libs/libpng:0=
        media-libs/libsdl2
        media-libs/libv4l
        >=media-libs/portaudio-19_pre
-       media-video/ffmpeg
+       >=media-video/ffmpeg-2.8:0=
        virtual/libusb:1
        virtual/udev
        gsl? ( >=sci-libs/gsl-1.15 )
-       >=media-video/ffmpeg-2.8:0=
        pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
        qt5? (
                dev-qt/qtcore:5
@@ -37,12 +41,8 @@ RDEPEND="
 "
 # linux-headers: bug 448260
 DEPEND="${RDEPEND}
-       dev-util/intltool
-       sys-devel/autoconf-archive
-       sys-devel/gettext
        >=sys-kernel/linux-headers-3.4-r2
        virtual/os-headers
-       virtual/pkgconfig
 "
 
 S="${WORKDIR}/${MY_P}"
@@ -73,5 +73,5 @@ src_configure() {
 
 src_install() {
        default
-       find "${D}" -name '*.la' -delete || die
+       find "${D}" -name '*.la' -type f -delete || die
 }