net-mail/rss2email: py3[78] + QA
authorSebastian Pipping <sping@gentoo.org>
Mon, 20 Apr 2020 07:28:05 +0000 (09:28 +0200)
committerSebastian Pipping <sping@gentoo.org>
Mon, 20 Apr 2020 07:28:51 +0000 (09:28 +0200)
Closes: https://bugs.gentoo.org/718436
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.99, Repoman-2.3.22

net-mail/rss2email/rss2email-3.11-r1.ebuild [new file with mode: 0644]

diff --git a/net-mail/rss2email/rss2email-3.11-r1.ebuild b/net-mail/rss2email/rss2email-3.11-r1.ebuild
new file mode 100644 (file)
index 0000000..2459d85
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python script that converts RSS/Atom newsfeeds to email"
+HOMEPAGE="https://github.com/rss2email/rss2email"
+SRC_URI="https://github.com/rss2email/rss2email/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/feedparser-5.0.1[${PYTHON_USEDEP}]
+       >=dev-python/html2text-3.01[${PYTHON_USEDEP}]
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+       distutils-r1_src_install
+       doman r2e.1
+}