dev-php/swoole-async: bump to v4.4.16
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 9 Mar 2020 15:10:38 +0000 (16:10 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 9 Mar 2020 15:10:38 +0000 (16:10 +0100)
Package-Manager: Portage-2.3.91, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-php/swoole-async/Manifest
dev-php/swoole-async/swoole-async-4.4.16.ebuild [new file with mode: 0644]

index 9ef8b7fab79ac826bb9564a5591f4d81a993879f..4735139323d5183b5cb460661453c1968f5821c8 100644 (file)
@@ -1 +1,2 @@
 DIST swoole-async-4.4.12.tar.gz 417674 BLAKE2B 77a96f53b1b159b558eb4759fe172e4a3b8f2648cd9f49252d89508eb56b4d342b178fa3c84d6a425c300a286063b4d32a05d09a3da4f3769be4c25a9800783c SHA512 adfb761803e5ec93c30aa2a4bbc312a2f43287a54cd237c0a87237dfcbfe1e6daa3d57ec2cdf15720202aa9a7830ed67ab2efdf2f7dd81989c3693e91bc22143
+DIST swoole-async-4.4.16.tar.gz 419094 BLAKE2B 7b93a0d2eb8a9597a68871783c60746c832b2eb1dce89a0f82ca6df2ee20151f910ad4f8ebb6a453bea3b7c2cc274266614f147b34c21a089ff9cc4ca0f73d1c SHA512 cf4bfc3c86740e343774b2cddc0ef2386f522e7929c160bc10d47ebe0b8f8d63dbcc82e70b7f3f30e7f7c102ebd42b02cddf4c3e1a0289f0e45147ddbd9aa546
diff --git a/dev-php/swoole-async/swoole-async-4.4.16.ebuild b/dev-php/swoole-async/swoole-async-4.4.16.ebuild
new file mode 100644 (file)
index 0000000..09b9d48
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PHP_EXT_NAME="swoole_async"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_SAPIS="cli"
+DOCS=( README.md )
+
+USE_PHP="php7-1 php7-2 php7-3 php7-4"
+
+inherit php-ext-pecl-r3
+
+SRC_URI="https://github.com/swoole/ext-async/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/ext-async-${PV}"
+PHP_EXT_S="${S}"
+
+HOMEPAGE="https://www.swoole.co.uk"
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="An extension of Swoole, including the async callback style API"
+LICENSE="Apache-2.0"
+SLOT="0"
+# Tests will require pre-configured endpoint
+RESTRICT="test"
+
+DEPEND=">=dev-php/swoole-4.3"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug"
+
+src_configure() {
+       local PHP_EXT_ECONF_ARGS=(
+               --enable-swoole_async
+               $(use_enable debug)
+       )
+
+       php-ext-source-r3_src_configure
+}
+
+src_test() {
+       local slot
+       for slot in $(php_get_slots); do
+               php_init_slot_env "${slot}"
+               [[ -f tests/template.phpt ]] && rm tests/template.phpt
+               SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
+       done
+}