www-servers/nginx-unit: Upstream release 1.5
authorRalph Seichter <github@seichter.de>
Tue, 18 Sep 2018 13:59:54 +0000 (15:59 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 27 Oct 2018 12:08:48 +0000 (14:08 +0200)
This ebuild version supports NGINX Unit release 1.5 and allows
building PHP runtime modules.

Closes: https://bugs.gentoo.org/665362
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/9905
Signed-off-by: Michał Górny <mgorny@gentoo.org>
www-servers/nginx-unit/Manifest
www-servers/nginx-unit/metadata.xml
www-servers/nginx-unit/nginx-unit-1.5.ebuild [new file with mode: 0644]

index 9faa8c2bda7c7e60448f6156dd40cd6f2e454db6..9bfd8b4574b3915f560dc8db6f8c9f50e612f9d1 100644 (file)
@@ -1 +1,2 @@
 DIST nginx-unit-1.3.tar.gz 401670 BLAKE2B 34a0ed9631c7061d1c71f8335103b0e266ef6f949afeb8cef283a7b5dd6c9f0a4835f20fdedd091af6950cd0897cb1ab48dea9f475e1b75a2872da7ac0090d10 SHA512 63a47b920bfdae7a7e034d616f520b27b46151a299cf5854373f7f8472043de0ffc98f9d62317c46e637857e0ef24668ded99be6e058315acf25b4e1c7f1ed09
+DIST nginx-unit-1.5.tar.gz 437636 BLAKE2B 9f7b89a800c933cc6d55a444c5a6c6326cf1694062026419af5e8a13e68b35c47b631d961611342e20c3d9338ca727ed7cc38c27b43443ec3f9abafd18f6684a SHA512 bde6bc7720cff03bf3967fde265c6763fc84f597a7c785eae0174726cb8ad7676f0adade892c2944abad831a667fff250a75aeacdca2d1bffb8c0f8fcd291ebd
index 7660440b3f514c8852f6ec98f8a5686785e366c6..73c93269432bf4d862cd42eec02141bd1b0f4c85 100644 (file)
                reconfiguration of specific application parameters as needed by the
                engineering or operations.
        </longdescription>
+       <use>
+               <flag name="php5-6">Support for PHP 5.6</flag>
+               <flag name="php7-0">Support for PHP 7.0</flag>
+               <flag name="php7-1">Support for PHP 7.1</flag>
+               <flag name="php7-2">Support for PHP 7.2</flag>
+       </use>
        <upstream>
                <remote-id type="github">nginx/unit</remote-id>
        </upstream>
diff --git a/www-servers/nginx-unit/nginx-unit-1.5.ebuild b/www-servers/nginx-unit/nginx-unit-1.5.ebuild
new file mode 100644 (file)
index 0000000..e1eb363
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{3,4,5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-0 php7-1 php7-2"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} ) python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+       php5-6? ( dev-lang/php:5.6[embed] )
+       php7-0? ( dev-lang/php:7.0[embed] )
+       php7-1? ( dev-lang/php:7.1[embed] )
+       php7-2? ( dev-lang/php:7.2[embed] )
+       python? ( ${PYTHON_DEPS} )
+       ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+       use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+       ./configure \
+               --control=unix:/run/${PN}.sock \
+               --ld-opt="${LDFLAGS}" \
+               --log=/var/log/${PN} \
+               --modules=$(get_libdir)/${PN} \
+               --pid=/run/${PN}.pid \
+               --prefix=/usr \
+               --state=/var/lib/${PN} || die "Core configuration failed"
+       for flag in ${MY_USE} ; do
+               if use ${flag} ; then
+                       ./configure ${flag} || die "Module configuration failed: ${flag}"
+               fi
+       done
+       for flag in ${MY_USE_PHP} ; do
+               if use ${flag} ; then
+                       local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+                       ./configure php \
+                               --module=${flag} \
+                               --config=${php_slot}/bin/php-config \
+                               --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+               fi
+       done
+}
+
+src_install() {
+       default
+       diropts -m 0770
+       keepdir /var/lib/${PN}
+       newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}