x11-misc/x11vnc: use myconf array for econf args
authorAlexander Tsoy <alexander@tsoy.me>
Fri, 31 May 2019 21:57:38 +0000 (00:57 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 1 Jun 2019 08:15:10 +0000 (10:15 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Alexander Tsoy <alexander@tsoy.me>
Closes: https://github.com/gentoo/gentoo/pull/12071
Signed-off-by: Michał Górny <mgorny@gentoo.org>
x11-misc/x11vnc/x11vnc-0.9.16-r3.ebuild

index 644cbc1fdbcf6260aef5a3bb9ebfffae61d8a88b..752f08e414d20ab968083ee62a284b239f76e26b 100644 (file)
@@ -53,21 +53,23 @@ src_prepare() {
 
 src_configure() {
        # --without-v4l because of missing video4linux 2.x support wrt #389079
-       econf \
-               --without-v4l \
-               --without-xkeyboard \
-               --without-fbpm \
-               --without-dpms \
-               $(use_with crypt) \
-               $(use_with fbcon fbdev) \
-               $(use_with ssl) \
-               $(use_with ssl crypto) \
-               $(use_with xcomposite) \
-               $(use_with xdamage) \
-               $(use_with xfixes) \
-               $(use_with xinerama) \
-               $(use_with xrandr) \
+       local myconf=(
+               --without-v4l
+               --without-xkeyboard
+               --without-fbpm
+               --without-dpms
+               $(use_with crypt)
+               $(use_with fbcon fbdev)
+               $(use_with ssl)
+               $(use_with ssl crypto)
+               $(use_with xcomposite)
+               $(use_with xdamage)
+               $(use_with xfixes)
+               $(use_with xinerama)
+               $(use_with xrandr)
                $(use_with zeroconf avahi)
+       )
+       econf "${myconf[@]}"
 }
 
 src_install() {